GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » General VR4 Discussions » Re: NEW OWNER OF 1687!!!
Previous thread Next thread

Re: NEW OWNER OF 1687!!!


4Grim
I deliver.
1948/2000


Galant VR-4 org Post #: 1121354 posted 05/02/13 09:12 PM     Remind Me!  Send Private Message   Edit Post      
Took a couple quick picks of my OMP belts mounted. Just have to buy the harness bar now.






91 GVR4 1948/2000
96 Galant 5sp DOHC 4G64T
2002 Montero Limited
1998 Montero "Winter Package"




Edited by 4Grim (05/02/13 09:13 PM)

Posts: 2478 | From: Orlando FL | Member Since: 09/30/04 | IP: (97.102.36.200) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1121357 posted 05/02/13 09:21 PM     Remind Me!  Send Private Message   Edit Post      
thank you, but what did you do with the lap belt ends? thats another problem im having...



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

4Grim
I deliver.
1948/2000


Galant VR-4 org Post #: 1121375 posted 05/02/13 10:49 PM     Remind Me!  Send Private Message   Edit Post      
Mount them where the stock lap belts bolt up to. I just need to buy the eyebolts to hook them up.



91 GVR4 1948/2000
96 Galant 5sp DOHC 4G64T
2002 Montero Limited
1998 Montero "Winter Package"



Posts: 2478 | From: Orlando FL | Member Since: 09/30/04 | IP: (97.102.36.200) | Report this post to a Moderator

turbowop
Hard Snarker
1051/2000



Galant VR-4 org Post #: 1121392 posted 05/03/13 12:29 AM     Remind Me!  Send Private Message   Edit Post      
These pics show how I mounted to the harness bar. To mount shoulder harnesses and lap belts to the stock seatbelt anchors you need these.










-Mark

A face only a grocery shopper could love.
1051

Posts: 11954 | From: Yakima, WA | Member Since: 04/29/01 | IP: (71.92.106.100) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1121429 posted 05/03/13 07:11 AM     Remind Me!  Send Private Message   Edit Post      
ok sweet, my harnesses already have the clip part so i just need to buy the eyebolts. is that the harness bar from number3? i really like it alot, how is it for passangers in the back seat though? i wont have people in there often, but from time to time there will be people back there.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

turbowop
Hard Snarker
1051/2000



Galant VR-4 org Post #: 1121482 posted 05/03/13 11:05 AM     Remind Me!  Send Private Message   Edit Post      
It's like a roller coaster seat for people in the back. But yeah, that's one of the bars that Harry made.



-Mark

A face only a grocery shopper could love.
1051

Posts: 11954 | From: Yakima, WA | Member Since: 04/29/01 | IP: (66.87.113.181) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1122385 posted 05/08/13 05:12 PM     Remind Me!  Send Private Message   Edit Post      
so i took my CAS off today to replace the gasket on it and i notice that there is a gap in the camshaft cap, so i pull off my valve cover and ugh ohhh, every single cam-cap was unbolted and looser then finger tight, they werent even touching the caps. the only ones tightened down to spec was the two caps that are right by the timing belt. so i tightened them up installed the CAS turned the car on and vroom -18 inhg, im pumped. i need to get some help now setting the timing because the CAS was off, redo the base idle and then start tuning. also my phantom overheating problem resurfaced, i think it may be another air bubble, after the car reached 219 today i shut it off and heard a small hiss, there was a crack in one line and two pin holes in another line. i think i need to rewire the 6 plug harness also because every time it gets touched it either turns off the fans or makes them run full time.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

desant78
Member ++
1662/2000
995/1000


Galant VR-4 org Post #: 1122386 posted 05/08/13 05:24 PM     Remind Me!  Send Private Message   Edit Post      
dude you must be so stoked fixing your vaccuum issue! Keep up the hard work!



i wanna go fast.

1991 GVR4 1662/2000 (parts car)
1992 GVR4 995/1000 (JSB)
2008 Evo X GSR (DD with bolt ons, 17x,xxx miles)

Posts: 732 | From: Clarksboro, NJ | Member Since: 06/23/10 | IP: (138.162.8.57) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1122387 posted 05/08/13 05:28 PM     Remind Me!  Send Private Message   Edit Post      
yeah for sure. im finally able to relax a bit, i've been super stressed over this not able to really do anything because i knew there was a issue that had to be fixed. now i can actually move forward. i also removed 5 of the caps to make sure that nothings was ruined by running the car with lose caps, there weren't any marks. thank goodness for that.



138/2000
152/1000


Edited by transparentdsm (05/08/13 05:30 PM)

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1122504 posted 05/09/13 10:21 AM     Remind Me!  Send Private Message   Edit Post      
so getting my parts for sale together and going through boxes and ran across a meth kit that i had bought a while back. now im trying to debate on weather to use it or sell it. i really want to use it, but it needs some things and i need to spend like 150$ to get the kit in my car the way i want it. i could technically install it the way it is, but i wouldn't be happy and i would have to use the washer fluid bottle and i would have to mount the whole thing in the engine bay. i want to mount this in my trunk, keep everything hidden and not look like i have a meth kit in my car. anyone who has meth experience please help me make a decision.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1123728 posted 05/16/13 12:59 AM     Remind Me!  Send Private Message   Edit Post      
so i ordered all the parts to finish the meth kit in my car the way i want to install it. im just waiting for the package to come in the mail. today i did some cleaning up of the engine bay. installed a set of PTE 780cc injectors with all new o-rings, the front grill, spark plug cover, cut then painted the bracket and relocated the coil pack, put the clear HKS timing belt cover on and installed my fog lights. i have a heat shield that i painted black and im going to make some brackets for it to fit over the forced performance manifold. i hope to install that tomorrow. here are pictures of what i did today. i only have 1 fog light in just to see how it looks for the time being. i think they might be to small. what about you guys?








got up real early this morning and started getting things done. finished up the heat shield and bracket and installed it.






i also had a spare heat shield that was half rusted all the bolt holes were to bit for bolts so i cut it up for an o2 housing/alternator heat shield. its hidden so i dont mind it looking bad.



while i was at it i made a bracket for the electronic boost controller thats controlled by ECMLink.




and the final product.

im done under the hood for a while. im really really happy with how everything came out. i have the rest of the meth kit on the way, but im probably going to hold off on using it for a while as id like to get the car tuned and running real well and enjoy it for a while before i start playing around again. now i just need to get the harness bar and put the passenger seat in and the car is done.

even though its never done and im actually moving the gauges into the glove box now and working on building a carputer to straight run link all the time and have a constant datalog going and use that as my gauges.



138/2000
152/1000


Edited by transparentdsm (05/16/13 10:05 AM)

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1124334 posted 05/20/13 11:50 AM     Remind Me!  Send Private Message   Edit Post      
got all the meth stuff in the mail the other day and i had some free time this morning and decided where to mount the bottle. i put it here.



still trying to figure out where to put the pump, im thinking i might make some brackets and put it here.


if anyone has a better place or a different idea, let me know.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1125141 posted 05/25/13 07:16 AM     Remind Me!  Send Private Message   Edit Post      
so i tried a few spots, this is what i liked the most and found easy to run the lines.

carpet tucked under and around the pump

and the routing of the hoses.


i haven't run any of the lines yet. not sure when im going to, but i really wanted to do the trunk portion.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1126516 posted 06/03/13 07:15 PM     Remind Me!  Send Private Message   Edit Post      
so,moving time is coming close and i have gotten this thing almost completely finished. i have had the car running for the last week or so now and everything is perfect. no leaks, no noises, solid 145 psi across the boards, pulled the plugs today and they were perfect after 1000 miles, perfect vacuum, pulls super hard and feels great. all of the hard work and careful planing and taking my time was more than worth it. i don't think i could be happier. now i just have to rebuild the driveshaft, do inner tie rod end, boots, put in a cat, get an alignment and have my wideband bung welded in.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1128811 posted 06/18/13 01:54 PM     Remind Me!  Send Private Message   Edit Post      
so car started to make some noise, got worse and worse, hoping it would hold out till i could get to phils(dynastylsd) place, then yesterday while pushing my clutch pedal down it felt chunky. so i woke up this morning and pulled the trans out of the car.

after an hour and 20 minutes

here is what i found.

as you can see the collar or sleeve broke off and was laying on the input shaft and just getting torn up something horrible.


while i was pulling the transmission out, the throw out bearing fell out in 2 pieces and im not sure if it can be seen, but the retainer clip is bent and won't stay in throw out bearing.




here is a little bit of the metal shavings that were left on the pressure plate and the starter.



thankfully the pressure plate and the clutch disc were still in perfect condition and the flywheel is still good. i ordered a new OEM throw out bearing and retainer clip, 3 bottles of mt-90 and 1 bottle of 75w90 redline gear oil. i was planning on bringing the transmission out to phil tonight and having him replace the bellhousing and check everything over, but my dad found a trans for 300 locally. im going to pick that up, install it in the car and hopefully be good to go. then bring the broken transmission out to phil(dynastylsd) and have him hold on to the transmission for a little bit while i save up the funds and buy a rebuild kit, new double syncro 2nd gear set, evo 3 5th gear set and a few other little odds and end for the transmission, then have him build me one beautiful transmission and then ship it out to me.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

LIV4PSI
dyslexic 1051
1501/2000


Galant VR-4 org Post #: 1128816 posted 06/18/13 02:44 PM     Remind Me!  Send Private Message   Edit Post      
The curse of having 3 running VR4s finally struck. Glad to hear you find a new transmission so fast



-Craig
1501 Build Thread


Posts: 1762 | From: O-H-I-O | Member Since: 11/24/11 | IP: (151.213.133.49) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1128820 posted 06/18/13 03:08 PM     Remind Me!  Send Private Message   Edit Post      
yeah, but its all good. going to get the trans tonight and then just waiting on jnz for some parts and fluid. im just happy this happened now and not while i was driving across country in two weeks.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1128903 posted 06/19/13 07:54 AM     Remind Me!  Send Private Message   Edit Post      
went and picked up the transmission last night, in the dark... stupid. i got home brought it down stairs to my other trans to change parts, inspect, clean and other little things. well it turns out that the transmission sat for to long and will not go into 5/R. i looked inside the hole where the reverse switch sits and the shaft there is like rusted solid. thankfully the guy gave me his word on it and im going today to get my money back. now im on the hunt again. he has the transmission that i want, and i think we all want, laying in his house. the switchable awd/fwd jdm transmission, i didnt want to spend the money, but i might see if i can persuade him with some of the parts that i have for sale.

edit: got the trans to shift and everything and took the rear cover off to inspect, a little bit dirt, but all good..



138/2000
152/1000


Edited by transparentdsm (06/19/13 10:12 PM)

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1129160 posted 06/20/13 07:59 PM     Remind Me!  Send Private Message   Edit Post      
cleaned the trans out and up ran fluid through it a few times to clean everything out and were back up and running. threw my back out putting the trans in, but i can still walk so were all good. all good and happy, also brand new oem throw out bearing.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1129464 posted 06/23/13 03:22 PM     Remind Me!  Send Private Message   Edit Post      
about 350 miles with the new transmission and were doing good. the car has been such a dream, i also replaced the inner tie rods, boots, outer tie rods. put prothane bushings in the lower control arms, then gave everything a really good cleaning, car is real clean underneath now, cant wait to get it to the shop to put it in the air, weld in a wideband bung, rebuild the driveshaft, put new tires on, take some underbody shot of the car because of the rust-freeness of the car and then go get it aligned.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1129933 posted 06/26/13 06:29 AM     Remind Me!  Send Private Message   Edit Post      
was dying the carpet in 1078 due to water leaking issues and the carpet already being out of the car. so i figured if im going to do this i might as well do it for 138. carpet came out real nice. i used the rit stuff that one of the other forum members did the right-up on and i actually used an 18 gallon bucket and 2 boxes of the powder dye. i let the carpet sit overnight outside under a tarp because it happened to rain and i had no where to dry it except outside. next day it was nice out so i took the carpet out and it looks great, nice and dark. i let it sit outside all day in the sun and then hung it in my basement overnight by my de-humidifier to finish up drying it out 100%. i will take pictures later as im reinstalling the carpet and evo seats.



138/2000
152/1000


Edited by transparentdsm (06/26/13 06:30 AM)

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (70.44.0.205) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1135995 posted 08/11/13 06:44 PM     Remind Me!  Send Private Message   Edit Post      
Ok so it has been 6000 miles and 2 oil changes and the VR4 is still running super strong. i love my car. its so much fun.

im starting with the pictures of the new carpet installed.



i think it came out really good.

the front is a little dirty, but at the same time i drive the car so i kinda like it to be dirty.


after we got to tahoe i decided to add a strut tower bar. made a bit of a difference through turns and it looks pretty good in there.



138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (24.176.247.34) | Report this post to a Moderator

omertaitalia
Member +
435/2000


Galant VR-4 org Post #: 1136044 posted 08/12/13 12:26 AM     Remind Me!  Send Private Message   Edit Post      
sorry shane haven't been on in a while, so your back in tahoe now? pm me, gotta catch up.



#616-1000-sold
#435-2000
1992 Mistubishi Expo AWD 7 pass. van (4g63 swapped)
2010 Ducati 848

Posts: 410 | From: Downtown Los Angeles CA/Lake T... | Member Since: 05/07/09 | IP: (76.169.141.36) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1139220 posted 09/05/13 08:45 PM     Remind Me!  Send Private Message   Edit Post      
so i did a little work on 138 today. painted the underside of the hood, removed the heat sheild and opened the vents so there functional, ran the rest of the lines for the meth kit, drilled, tapped and lightly ported the throttle body elbow and then jb welded the nozzle in place, added a FIAV block off plate that i had laying around.














138/2000
152/1000

Posts: 3654 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (108.162.215.198) | Report this post to a Moderator

Steve885
Member
885/1000


Galant VR-4 org Post #: 1139240 posted 09/05/13 11:15 PM     Remind Me!  Send Private Message   Edit Post   
Nice work!!! Does the owner of the evo even know what your driving...I've come across so many evo drivers that don't know the origin of the car. Not that it matters

Posts: 228 | From: Concord ca | Member Since: 12/07/12 | IP: (199.27.128.24) | Report this post to a Moderator


Pages: 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16
Previous thread Next thread

Extra information
0 registered and 16 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 61110

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.231 seconds in which 0.174 seconds were spent on a total of 13 queries. Turbo powered.


Hertz's Galant VR-4 Page