The Top Mitsubishi Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

ETACS location

makedollarz

Well-known member
Joined
Aug 24, 2003
Messages
261
Location
Phoenix
My door locks, dome lights, and door lights don't work. A Search seems to point to possibly a bad ETACS? I have a parts car that I could swap one from to test and see if it's the issue, I'm just not positive where it's located. Does anyone possibly have a picture of it? I understand it's by the fuse box under the driver dash but anyone with a good description of the location would greatly help.
 

makedollarz

Well-known member
Joined
Aug 24, 2003
Messages
261
Location
Phoenix
Ok so unfortunatly I have a lot more electrical issues going on that I thought. I tried to swap the ETACS box to hopefully fix my door lock, dome light, and seatbelt issue, but after swapping it with a different unit, nothing changed. Its obviously not my problem but just out of curiosity, the ETACS units werent the same...

this is the 91 unit...



This is the 92 unit...



Does this make any differnce, the 92 one was know to be working properly.

Issue 2
The passanger seatbelt works fine, the driver side does not work at all. I swapped the unit out with a known working one and it still doesnt move at all when you open/close the door. I also checked the where it plugs im at the motor with a voltmeter and it was reading 12v.

Issue 3
Dome lights do not work at all, I checked these also at the plugs with a voltmeter and they were reading at around 5v. I didnt replace the bulbs but they all look to be fine. I cant imagine all the bulbs being bad.

Issue 4
The 10amp Tail light fuse that is under the hood blows after about 1 min of turning the lights on.

Issue 5
Door locks do not work at all, I was hoping this was due to a bad ETACS but after swapping them I dont know what to look for.

And last thing I can think of is I cant figure out where this plug goes after swapping dashes. Maybe it has something to do with everything.

Here's a pic looking up from underneath the driver dash...







And from the top with the dash removed...






It has 4 green wires, 2 with white stripes and 2 with grey dots.

Thanks so much for any help.
 
Last edited:

makedollarz

Well-known member
Joined
Aug 24, 2003
Messages
261
Location
Phoenix
Damn I was hoping that missing plug was the magical solution to all my problems, anyone else have any ideas ?
 

fuel

Well-known member
Joined
Feb 23, 2009
Messages
2,165
Location
Toronto, ON, Canada
regarding the tail lamp fuse blowing - you haven't recently fitted a stereo and accidentally mistaken the green 'illumination' wire in the radio harness as an earth wire? I did that once (as did many others) and it results in the fuse blowing and other weird things.
 

makedollarz

Well-known member
Joined
Aug 24, 2003
Messages
261
Location
Phoenix
No, haven't recently put in a new radio. The factory radio harness is untouched, and has no radio plugged in at all. I did put an alarm and remember having to tap into a green wire, i think under the driver side floorboard, I had to pull back the carpet to get to it. I'll double check that but I'm pretty sure I tapped all the correct wires as it was the second time I've put an alarm on a galant and the other one cars alarm/taillight fuse worked fine.
 

Leon_R

Well-known member
Joined
Aug 30, 2011
Messages
214
Location
Chelmsford, MA
Quoting makedollarz:
Ok so unfortunatly I have a lot more electrical issues going on that I thought. I tried to swap the ETACS box to hopefully fix my door lock, dome light, and seatbelt issue, but after swapping it with a different unit, nothing changed. Its obviously not my problem but just out of curiosity, the ETACS units werent the same...

this is the 91 unit...







Here is a stupid question: you can see one of the ETACS moutning bolts, but how do you get to other one? Fusebox harness is in the way. Is there an easy way to get it out of the way?
 

snohacking

Well-known member
Joined
Mar 16, 2010
Messages
233
Location
Menomonee Falls, Wi
No there no easy way I just took mine out a few days ago. I had to unbolt the fuse box and take off the bracket. Then more some wires out of the way and use a huge extension to get it. Good luck took my more then a hour to get it out. Putting it back in should be fun
 
Last edited:
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Classifieds Listings

Top