The Top Mitsubishi Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

help me please

i got my vr4 to start but its won't go more than 20 mph it jerks back and forth any ideas . The car sound fine but when I drive it it starts jerking. Help me /ubbthreads/images/graemlins/banghead.gif it giveing me a headache
 

Terry Posten

Well-known member
Joined
Dec 16, 2003
Messages
9,009
Location
Davenport, Iowa USA
Sounds like "limp home" mode.

Is the MAS plugged in? Any check engine codes? Have you performed a boost leak test? Has the ECU been capped yet?
 

I mod maf to a gm. Don't know how to check the boost. And ecu I was told was fine
 

464/2K

Well-known member
Joined
Oct 21, 2003
Messages
4,671
Location
Denver,Co
Pm sent
 

I had the same problem in a previous mitsu of mine. It would buck back and forth if I tried to go over 3k rpms. It wouldn't do it if I had the mas unplugged though. Turned out to be a bad ECU. I would start there if I were you.
 

Terry Posten

Well-known member
Joined
Dec 16, 2003
Messages
9,009
Location
Davenport, Iowa USA
Stevep is the best one for a bad ECU. I only do caps, socket, cleaning and minor run repair.

click is his profile page.

click is is web site.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Recent Classifieds Listings

Top