The Top Mitsubishi Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

1517's thread ***More pics added 12/31***

dlesser

Well-known member
Joined
Jun 26, 2011
Messages
61
Location
Westminster, CO
Uhh ohh sounds like something bad happend. Any update?

Edit: Need to look at post times /ubbthreads/images/graemlins/banghead.gif sorry
 
Last edited:

So I drove the 65 miles or so to go help out Diego in Greeley. The car drove real nice the whole way up there, never even made me think something would be wrong. I chit-chatted Diego for a few minutes and then we went to get into my car so I could show off a bit and we could get food also. The car didn't want to go into gear, so we took his roommate's RX-7 instead. After coming back and working on his car, the time came for me to try and get this thing home. I started it in gear, and the clutch was dragging enough that the car backed itself out even though my foot was buried to the floor on the clutch. I shoved it out of gear and the car died. I re-started it, and tried to put it in first. It went right in, then into second, third, fourth, fifth and reverse with absolutely no grind or "block out", and it wasnt making any noise. I tried driving away, made it about 400 feet, and then I heard the worst sound I think I've ever heard from any of my Mitsubishi's. It was like 6000 school teachers dragging their fingernails across a chalkboard all at once. So I called for rescue in the form of a Powerstroke and a trailer.

After disassembly, here's what I found.















On a positive, I snapped a couple of pics of my custom gauge pod for your veiwing pleasure. The bottom panel is still in the works, the guy that built it just ran out of the glue he uses for attaching the vinyl the the MDF board.





 
Last edited by a moderator:

4Grim

Well-known member
Joined
Sep 30, 2004
Messages
2,516
Location
Orlando FL
Why am I not surprised your ACT took a crap. Never heard though of the PP going bad...just their discs which happened to me.

Whats your next clutch setup in mind?
 

Lightning1

Well-known member
Joined
May 12, 2010
Messages
67
Location
IL
My act 3200 pp did the same thing about 6 months ago. That is what caused me to tear the car apart. Drove to work great, then pushed in the clutch to start it and you could feel something in the pedal and no gears. I switched the master and slave, and when I got down to do the slave, those damn teeth were in the bottom of the bellhousing. I thought it was a common problem for the act clutches?
 

Terry: yes this is an ACT 2600, Diego remembered correctly.

Dlesser: unfortunately I can't blame myself for this one. The bolts were all tight, all there, so I don't really know the "how and why" on this one.

4grim: I haven't thought about what clutch to use on this go around. Got a suggestion?
 

Brianawd

Well-known member
Joined
Apr 18, 2005
Messages
2,117
Location
Portland OR,
ACT at its best.

Where is the person that is on this board that used to work for ACT and always said there were great clutches. Care to chime in on this one?
 

I'm not putting a Centerforce in it. I have seen bone stock 4g63t powered cars kill Centerforce clutches in only a few months.
 

dlesser

Well-known member
Joined
Jun 26, 2011
Messages
61
Location
Westminster, CO
I have a used 2600 if you just want to get it back and running. I need to check at the shop to make sure I didn't toss it. If your interested let me know...its free. I won't put another ACT clutch in my car.
 

91VR41400

Well-known member
Joined
Jul 24, 2004
Messages
109
Location
Rockville MD 20852
Sucks to see that... ive been running an ACT 2600 in my AWD 1g since 2002 with zero problems. Ive heard stories about there disc hub cracking but never seen any PP failures. Guess its how people drive them /ubbthreads/images/graemlins/dunno.gif
 

Quoting dlesser:
I have a used 2600 if you just want to get it back and running. I need to check at the shop to make sure I didn't toss it. If your interested let me know...its free. I won't put another ACT clutch in my car.



thanks for the offer, but i'm going brand new. Maybe not ACT, but new.
 

Yeah, definitely some options there. I didn't realize CM had as many choices as they do.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Recent Classifieds Listings

Top