GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Newbies » Re: First time GVR4 owner 965/2000 (3xdsm owner) :)
Previous thread Next thread

Re: First time GVR4 owner 965/2000 (3xdsm owner) :)


chevyracer5613
Unregistered


Galant VR-4 org Post #: 935261 posted 09/28/10 06:25 PM     Remind Me!  Send Private Message   Edit Post      
boostdtalon- Wow he's got alot of stuff...thanks for that link depending on how much it'd cost to repair my current seats I might strongly consider those.....thanks again!

| | | IP: (98.24.143.50) | Report this post to a Moderator

HHIVR4
Aluminum Lung
1280/2000
138/2000



Galant VR-4 org Post #: 935266 posted 09/28/10 06:52 PM     Remind Me!  Send Private Message   Edit Post      
I have a set of stock seats that are/were in nice shape before storing them.
Im 4.5 hrs away though.I am planning a trip up to Greensboro but not sure exactly when it will be.Trying to schedule it around a funeral in D.C.
I could bring them up but let me give them a good inspection since they have been in storage for over a year.

Posts: 5446 | From: Hilton Head Island SC | Member Since: 10/06/03 | IP: (64.20.145.209) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 935289 posted 09/28/10 08:32 PM     Remind Me!  Send Private Message   Edit Post      
HHIVR4- That'd be awesome, after you inspect them if you wouldnt mind sending me a few pictures and a price i'd like to discuss the possible purchase of them with you.....I usually respond best to chevyracer5613 at aol dot com, also at my current stage with the car I am in no rush with the interior so I have a little time to spare....... plus I first need to get it running haha. Thanks for the heads up

| | | IP: (98.24.143.50) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 936427 posted 10/03/10 04:56 PM     Remind Me!  Send Private Message   Edit Post      
I thought i'd share a little update, I have almost finished pulling the motor out of my eclipse to go into the gvr4....I plan to have it out today and then clean it up over the next few days and hopefully install it next weekend. Here are a few pictures that I took while it was in my eclipse:







Yay it's out :-D


Edited by chevyracer5613 (10/03/10 05:39 PM)

| | | IP: (98.24.143.50) | Report this post to a Moderator

bmxkid415
Member
623/1000
199/1000


Galant VR-4 org Post #: 936731 posted 10/04/10 09:07 PM     Remind Me!  Send Private Message   Edit Post      
I left a set of seats at my Fathers house in NY, They would have been great for that car. I hope the correct door panels came with that. In Feb I sent them to one of the last owners.



Cory McGee
1997 Jeep Cherokee - DD/Tow Rig
1992 Galant VR4 #623 - SOLD
1992 Galant VR4 #199 - Parted and Gone

Posts: 204 | From: Bradenton FL | Member Since: 01/27/08 | IP: (72.185.236.53) | Report this post to a Moderator

misfitsnemesis
Junior Member
602/2000


Galant VR-4 org Post #: 936735 posted 10/04/10 09:35 PM     Remind Me!  Send Private Message   Edit Post      
Nice looking cars man. Good luck with it.

Posts: 72 | From: bristol TN | Member Since: 02/22/06 | IP: (216.41.248.229) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 936746 posted 10/04/10 10:25 PM     Remind Me!  Send Private Message   Edit Post      
bmxkid415: Well if your ever bored and headed up to NY let me know . I believe the correct door panels came with it....it came with a second set that are black and look normal to me.....I have put one in so far just havent got around to installing the others yet.

misfitsnemesis: I appreciate, I am sure I can use all the luck I can get haha

Question for anyone......the handle to my glove box is non existent......how do I get into it and or repair/replace it without damaging anything?

| | | IP: (98.24.143.50) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 937275 posted 10/06/10 05:47 PM     Remind Me!  Send Private Message   Edit Post      
Another update, I was finally able to free myself for a couple of hours and pulled the motor out of the GVR4......noticed a few "odd" things....but over all after a little money is put into her I think she will turn out to be a nice reliable ride






Btw in the last picture I placed a 14-b ontop of the ex. manifold just for size reference against my holset

| | | IP: (98.24.143.50) | Report this post to a Moderator

Boostdtalon
Member +++


Galant VR-4 org Post #: 937515 posted 10/07/10 10:35 AM     Remind Me!  Send Private Message   Edit Post      
Yeah that turbo is pretty big.

Posts: 913 | From: Buckley, Wa. | Member Since: 10/15/09 | IP: (65.188.240.110) | Report this post to a Moderator

Dbossman
Unregistered


Galant VR-4 org Post #: 938146 posted 10/09/10 10:10 PM     Remind Me!  Send Private Message   Edit Post      
That holset could eat that 14b and shit t25's.

| | | IP: (166.137.136.39) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 938213 posted 10/10/10 09:02 AM     Remind Me!  Send Private Message   Edit Post      
Dbossman: Haha...nice :-P

Update, I have the motor mostly into the car car.........about to go put the other mounts on it........I swapped my front suspension from my eclipse over since it had better shocks.........I also converted the front to 5 lugs.

Quick question, when I bought the car it allegedly came with "3000 gt vr4 front brake" but they look exactly the same as the ones that were on my galant (dual piston) except they were 4 lug and not 5......I didnt measure the rotors but they looked the same size also......are they indeed the same or was the guy I bought from confused?

| | | IP: (98.24.143.50) | Report this post to a Moderator

ScreaminE
Just don't like an idiot


Galant VR-4 org Post #: 938215 posted 10/10/10 09:08 AM     Remind Me!  Send Private Message   Edit Post      
It's a 3000gt SL brake set up not a VR4.



-Scott H.
1267/2000 - sold

Posts: 646 | From: Pittsburgh South Hills | Member Since: 09/04/08 | IP: (24.136.248.127) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 938284 posted 10/10/10 05:11 PM     Remind Me!  Send Private Message   Edit Post      
ScreaminE: Awesome, thanks for that info........hopefully I can find a set or rears off a 3kgt sl (or perhaps and awd dsm) that'll work for the car also

| | | IP: (98.24.143.50) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 938286 posted 10/10/10 05:21 PM     Remind Me!  Send Private Message   Edit Post      
Update: I dropped the motor in today and hooked up a few things (front axles,xfer case etc). I have a few pictures I will upload below, however what is odd is that it seems like the driver side motor mount I had in my eclipse puts the motor at a odd angle in the galant....I wonder of my eclipse (or maybe this car) was slightly bent somewhere when I made the mount? Anyhow I have it temporarily mounted (upside down) to hold the motor up while I bolt a few more things in place and then I am going to make a new one, and possibly a new rear motor mount as well. Does anybody happen to have some factory specs on the motors location relative to everything, mostly how much it should be rotated forward relative to some point. Also I am wanting to retain power steering and AC even though I dont have the pump/brackets/condenser for either so I am going to start sourcing out those part. I saw one post from a few years back about a guy using a electric powersteering pump off a 2g MR2.....but it never stated his success or failure, is anyone familiar with this mod? Also I noticed when I started swapping some of my suspension over, the galant has 4 mounting holes for the shock (at the top of the shock tower) where as the eclipse only had three.........any idea why the galant has an extra hole?





Edited by chevyracer5613 (10/10/10 05:22 PM)

| | | IP: (98.24.143.50) | Report this post to a Moderator

toybreaker Galant VR4.org Moderator
it's peace of mind at 100 mph plus
1990/2000


Galant VR-4 org Post #: 938290 posted 10/10/10 06:09 PM     Remind Me!  Send Private Message   Edit Post      
Did you use the motor mount brackets from the Galant motor?

The front mounting bracket is specific to the Galant.

Using the t/e/l mounting bracket may make the engine sit at an odd angle.

Project looks good so far!



the bitterness of low quality remains long after the temporary joy of a low price has faded

Posts: 3541 | From: Never Summer Ranch, Colorado | Member Since: 04/30/06 | IP: (208.54.90.49) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 938300 posted 10/10/10 06:49 PM     Remind Me!  Send Private Message   Edit Post      
toybreaker- I actually dont have a front motor mount currently.....my turbo is way to big for that , even after putting a 3/4" spacer on the ex. manifold I still had the grind the block down a little to clear the ex. housing on the turbo lol. I have the galant transmission mount (chassis side) in use with the t/e/l (transmission side) and the galant rear motor mount (chassis side) in use with the t/e/l (motor side)...if that made any sense....., thanks for the input and compliment :-D....its going to be alot of work but I am sure it'll be worth it :-D

| | | IP: (98.24.143.50) | Report this post to a Moderator

mr.mitsu
Member +++


Galant VR-4 org Post #: 938318 posted 10/10/10 07:40 PM     Remind Me!  Send Private Message   Edit Post      
There was never a "Canadian" vr4.

Plus, the cluster shows mph not km's.

It is interesting that it shows the gears of an auto

Posts: 798 | From: canada | Member Since: 04/28/03 | IP: (99.227.201.162) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 938345 posted 10/10/10 09:06 PM     Remind Me!  Send Private Message   Edit Post      
mr.mitsu- Thank for that info, it is indeed interesting...I am still not sure why lol

| | | IP: (98.24.143.50) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 938625 posted 10/11/10 07:01 PM     Remind Me!  Send Private Message   Edit Post      
Another update, I finally have the motor installed :-D.....I might have it fired up tomorrow or next week....depending on free time as the only thing really left to do (for it to run) is to install the ecu, make brackets for the oil cooler and make brackets/mount my dual oil filter relocation kit.......aside from that she should fire up and run pretty good.......she's still a little far from being street ready but is getting alot closer

Question, I had to move my radiator a inch or so forward to clear my turbo.....and I was trying to figure out where/how the condensor bolts/mounts......but i have yet to figure it out.....perhaps b/c my radiator is now in its spot?





I am waiting to get more big tubing so i can turn it 90* down and install the big air filter inside the fender (or just putting a bigger filter on the current config and build a air box....one of the two

I am still trying to figure out what the center bracket is, where the windshield wiper fluid resevior is trying to mount.......and if that power steering pump bracket will bolt to my 2g-esque motor............


Edited by chevyracer5613 (10/11/10 07:03 PM)

| | | IP: (98.24.143.50) | Report this post to a Moderator

Boostdtalon
Member +++


Galant VR-4 org Post #: 938631 posted 10/11/10 07:13 PM     Remind Me!  Send Private Message   Edit Post      
IIRC the wiper reservoir bolts to the back of the passenger side strut tower.

Posts: 913 | From: Buckley, Wa. | Member Since: 10/15/09 | IP: (65.188.240.110) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 938640 posted 10/11/10 07:40 PM     Remind Me!  Send Private Message   Edit Post      
boostdtalon- Thanks,I will give that a look tomorrow

| | | IP: (98.24.143.50) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 940273 posted 10/16/10 06:35 PM     Remind Me!  Send Private Message   Edit Post      
*update* I finally got the motor wired up and everything, had to replace the radiator because the one that came with it was busted.....luckily I had a nice oem style aluminum core laying around that I picked up a couple of years ago (I guess back then I knew I would be needing it now lol)........also found and fixed a very annoying/small water leak that I had yay!

Now onto the other side of things, the motor turns over....and turns over much faster then my other cars oddly enough.......however I am not getting fuel (untill I get fuel I dont know about spark either)....the motor ran perfect before I pulled it so I doubt there are probelms there, however I am not sure if it is the fuel pump, fuel pump relay, ecu etc. I am trying to dig out my old palm so I can hook up to the obd port and pull the CEL and hopefully test the fuel pump ( I tried giving 12 v to the jumper wire near the master cylinder but it didnt seem to do anything).......also the fuel gage shows like 1/8 tank of gas.....I added a couple of gallons and it didnt change but perhaps it wasnt enough to register? I also am not getting oil pressure yet.........but perhaps it just has alot of air in the lines (spun the motor over about 4 times at 10 seconds each).

Hoping to spend some more time on it tomorrow, if not then perhaps next week

| | | IP: (98.24.143.50) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 945805 posted 11/02/10 08:40 PM     Remind Me!  Send Private Message   Edit Post      
Just thought i'd give a quick update, engine runs on starter fluid for a second :-P.......fuel pump doesnt seem to be doing anything so I am saving up a little and trying to decide whether to go back with stock , evo8 or a 255......probably whatever winds up being the best deal and I can get the quickest. Aside from that I think I killed my starter trying to prime the engine.....yay for autozone warranties (got a new one today).....the motor would turn over a little then make a weird grinding/clunking noise.........it frightened me at first b/c I hadnt got oil pressure yet but luckily it looks like it was the starter, and the motor turns over by hand nicely.

Anyhow been busy working on my 38' gooseneck......still not sure how I am going to convert the rear to 5 lug and retain AWS.......but i'll look into that later, also slightly considering a electric power steering pump off a 2g MR2...one less thing to bolt to the motor and then perhaps I could swap to the 4 bolt rear end and still retain AWS ? (if I recall right the stock 3 bolt has a PS pump built in...but aside from that its the same as the 4 bolt?)

Ill provide pictures in the next week or so........hopefully she'll be on the road running nice within the next month or two :-D

| | | IP: (98.24.143.50) | Report this post to a Moderator

Boostdtalon
Member +++


Galant VR-4 org Post #: 945809 posted 11/02/10 08:52 PM     Remind Me!  Send Private Message   Edit Post      
my car is swapped and still has the AWS even though it's not working at the moment since lines are partially disconnected.

Posts: 913 | From: Buckley, Wa. | Member Since: 10/15/09 | IP: (65.188.240.110) | Report this post to a Moderator

chevyracer5613
Unregistered


Galant VR-4 org Post #: 946029 posted 11/03/10 01:33 PM     Remind Me!  Send Private Message   Edit Post   
boostdtalon- I assume by swapped your referring to the 4 bolt swap.....unless I have read bad info on the net (which is possible) I am not sure I understand how you could even have a working AWS with the 4 bolt rear? I thought the stock 3 bolt rear had a power steering pump for the rear steering rack? If you removed that pump seems like the rear steer wouldnt really react when you turned the wheel? Perhaps I am missing something though because i'd love to retain AWS and eventually attempt to improve on it stock design but i'd also like the additional strength of a 4 bolt and the ability to use my 5 lug rims.

On a partial side note, i havent decided if its worth it or not to try and keep the ABS......I have read a couple different posts taking about swapping the abs rings or using different hubs, swapping computers etc. etc. Is there a easy way to have a 4 bolt rear, aws gvr4 with ABS? The only reason I am curious isnt really for the alleged benefit of emergency braking but more because it would allow me to eventually look into enabling a traction control system that would/could apply a certain amout of brake at a certain corner given a particular algorithim. I understand this gvr4 isnt a high end sports car in todays standards but i'd like to leave my options open if possible for some interesting upgrades in the future :-D.

| | | IP: (152.15.180.156) | Report this post to a Moderator


Pages: 1 | 2 | 3 | 4 | 5 | 6 | 7
Previous thread Next thread

Extra information
0 registered and 21 anonymous users are browsing this forum.

Galant VR4.org Moderator:  Hertz, curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating: *
Thread views: 33253

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.111 seconds in which 0.059 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page