GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » General VR4 Discussions » Re: 613/2000 update/status/build?
Previous thread Next thread

Re: 613/2000 update/status/build?


diambo4life
Member
476/2000


Galant VR-4 org Post #: 1233713 posted 11/23/16 08:12 AM     Remind Me!  Send Private Message   Edit Post      
Keep at it man. I have been there where you fall out of love of the car but I find myself back at it after letting it sit for a couple months. I have a daily that is very lightly modded so it keeps me occupied.



1990 GSX: New project..
1991 Belize Green GVR4 #476/2000: 710WHP/501TQ (dynojet)in 2014, Street trim, 3400lbs! [email protected] (wastegate)
91 Talon: [email protected] (quickest) [email protected] (fastest) 3200lbs, 17" street tires in 2009 (sold.)

Posts: 240 | From: Edmond, OK. USA. | Member Since: 07/07/13 | IP: (64.135.58.130) | Report this post to a Moderator

turbohf
anyone even read this?
613/2000


Galant VR-4 org Post #: 1233732 posted 11/24/16 02:14 AM     Remind Me!  Send Private Message   Edit Post      
i usually get really pumped, spend $1-3k on her, drive her for a month or 3. then something goes wrong, or loose interest and it sits for a month or 6.


got some motivation from buddy. going to mess with idle tomorrow. look for oil leak, then drop the front crossmember to get to oil leak... pretty sure its the oil drain. so some more hondabond, redloctite, new drain hose... then some tuning till there is no more clutch. buddy thinks he may have a 2900 ACT. hopefully he has it, hooks me up, plus a new street disc, fidanza rebuild, 25-30ish psi = win.

if im back in love. then ill have my work do a full detail (i work at a dealership), maybe some better/new stereo equipment and drive.... run a 11.00et this spring, get pissed and sell lol


stay tuned! likely to change my mind daily LOL.



Dustin
1991 GVR4 #613
1966 Chevrolet Chevy II Nova 400 4dr Sedan V8

Posts: 540 | From: Lake Stevens, WA | Member Since: 11/18/11 | IP: (50.34.221.167) | Report this post to a Moderator

thecman02
too lazy to look
580/1000


Galant VR-4 org Post #: 1233823 posted 11/27/16 10:41 PM     Remind Me!  Send Private Message   Edit Post      
Don't sell her. I just sold my girl. Nothing but regret. :-(



580/1000
2013 Max Effort Winner
-Chris

Posts: 912 | From: Kalamazoo,MI | Member Since: 11/03/07 | IP: (97.95.124.82) | Report this post to a Moderator

turbohf
anyone even read this?
613/2000


Galant VR-4 org Post #: 1233830 posted 11/28/16 11:44 AM     Remind Me!  Send Private Message   Edit Post      
she just sits, and i spend money. last time it was like 3k to get her out of jail...



so the other day...friday? anyway i pulled the front crossmemeber at the advice of a friend. wow, wasnt hard at all, and had a great view of all the underside of the turbo. (not sure why i havent done that before to get under there) could reach damn near everything too. thought that the oil line may have been rubbing and had been cut, it was rubbing a little, replaced it anyway. shouldnt rub anymore either. gave all the oil pan bolts i could reach a good snugging. i really dont see where it was leaking from. started the engine and it ran for 20mins or so till it got to about 205*. and i *think* it was leaking from one of the turbo oil drain bolts. think i fixed that. want to top off with oil and check it running on level surface.

i have a list but if i remember:
wire fans to ecu
hvac vents need replaced
NEEDS TUNED!
noise from RF i would like to find
some detail/paint touchups
oh, and i bought some black molding to replace chrome crap all way around the car. i ripped the one out the bumper, made a mess, bought eraser wheel to remove the mess. should be time consuming and fun






Dustin
1991 GVR4 #613
1966 Chevrolet Chevy II Nova 400 4dr Sedan V8

Posts: 540 | From: Lake Stevens, WA | Member Since: 11/18/11 | IP: (172.76.105.29) | Report this post to a Moderator

turbohf
anyone even read this?
613/2000


Galant VR-4 org Post #: 1233855 posted 11/29/16 07:33 PM     Remind Me!  Send Private Message   Edit Post      
well. in keeping with my recent updates that seeming have not much to do with selling or running 10s like title suggests...


i did a bunch of research, loaded all the pages to the tablet. went to work on the Galant.
~figured out wtf i had done to the wiring to the fans, removed rocker switch in cabin
~ran new wire to ECU to ground trigger relay for fans
~got pissed as it seems i dont have pin 53 egr? my notes where for egr, so had to track down and use the fps... hope/think im looking at these pinouts correctly
~re-wired wideband into ECU. was on baro before. thats now MAP for SD conversion. so now its on O2.
~got into ECMLink, swapped O2 front to WB, simulated narrowband off that. done? i think.
~also reset TPS, and made sure idle switch was off
~FPS to Fan control.... well shit. i fought with this for way too long. couldnt find my answer, well, seemed that what i was looking for should be right in front of me. it wasnt. turns out computers arent my thing. and firmware and software versions are not the same (i knew that), and i was looking in the wrong spot for firmware? anyway. flash new firmware = win. fans turn on at 185* and off at 176-180ish it seems? whatever. also set them to turn off on higher boost/tps/rpm. (20/50/3500 if it matters, open to suggestions)
~and may have narrowed down idle issue. first by plugging in the idle valve LOL. then some other small stuff. we will see. think i needs some battery offset work. doesnt like electrical loads on. also might have battery or something issue. it stone shut off like 2 times, showing 8.5v. after a couple key cycles/jumper cables it would fire off. i cleaned the shit out of all the battery terminals (inside/out, top/bottom). see if that works. fired right off without jump after that. oh when running fine it shows 14.2-14.5v consistent.


and while i was messing with all that, taking breaks to keep from getting pissed off too much, or just waiting for her to warm up for fans to cycle and see if she would start leaking any oil, etc.



making a mess. ripped out the chrome strip. left most all the foam. then take eraser (Astro wheel to be specific) in the drill and have fun. i got most the front bumper done i think. but it was getting dark/cold, have to verify in the light.
also have some new black moldings around here somewhere, ill try to get a pic/partnumber for anyone else. i have only been waiting to do this for like 5years? now.



so. starts, runs, idles (until it has a load on it), and doesnt leak oil. id say today is a win



Dustin
1991 GVR4 #613
1966 Chevrolet Chevy II Nova 400 4dr Sedan V8

Posts: 540 | From: Lake Stevens, WA | Member Since: 11/18/11 | IP: (172.76.105.29) | Report this post to a Moderator

iceman69510 Galant VR4.org Moderator
Turn Right Racing
855/2000


Galant VR-4 org Post #: 1233861 posted 11/30/16 07:09 AM     Remind Me!  Send Private Message   Edit Post      
Good progress.



91 VR4 855 Nile Black
92 VR4 828 Belize Green-SOLD
91 VR4 115 Nile Black -SOLD

Posts: 10716 | From: Michigan | Member Since: 03/05/01 | IP: (205.144.100.200) | Report this post to a Moderator

slugsgomoo
god hates stupid people
461/1000


Galant VR-4 org Post #: 1233875 posted 11/30/16 11:49 AM     Remind Me!  Send Private Message   Edit Post      
I want to see it when the chrome strip is gone... it's been something i've wanted to do basically since I bought the car... hate chrome so much...



-andrew
{witty signature}
#461 Kensington Grey - 2.0L/T67/etc
2015 Triumph Tiger 800 XCx
2014 Ford Focus ST

Posts: 3680 | From: Tacoma, WA | Member Since: 10/16/03 | IP: (160.202.136.10) | Report this post to a Moderator

turbohf
anyone even read this?
613/2000


Galant VR-4 org Post #: 1233876 posted 11/30/16 12:03 PM     Remind Me!  Send Private Message   Edit Post      
someone just posted a pic with a green vr4 with black moldings in it. think it was the what have you done to your vr4 today thread. one with the Volvo wheels.

also turbowop has black ones in his also.

wait, or you just want to see it molding less? odd, could work.



Dustin
1991 GVR4 #613
1966 Chevrolet Chevy II Nova 400 4dr Sedan V8

Posts: 540 | From: Lake Stevens, WA | Member Since: 11/18/11 | IP: (74.112.52.114) | Report this post to a Moderator

slugsgomoo
god hates stupid people
461/1000


Galant VR-4 org Post #: 1233877 posted 11/30/16 12:08 PM     Remind Me!  Send Private Message   Edit Post      
well, no i'd like to go black i think. I'm not sure anyone has done that with a KG car though?

I think with no molding will look funny

edit: I am dumb, looks like the car with volvo wheels is actually KG... 1000% better than chrome IMO.



-andrew
{witty signature}
#461 Kensington Grey - 2.0L/T67/etc
2015 Triumph Tiger 800 XCx
2014 Ford Focus ST


Edited by slugsgomoo (11/30/16 12:09 PM)

Posts: 3680 | From: Tacoma, WA | Member Since: 10/16/03 | IP: (160.202.136.10) | Report this post to a Moderator

badams
Bungie Battery
50/1000


Galant VR-4 org Post #: 1233904 posted 11/30/16 09:39 PM     Remind Me!  Send Private Message   Edit Post      
Agreed, the black looks good with the volvo and the stock wheels. For as cheap as the strip material is, it's well worth the change.



-Blake

Posts: 121 | From: KC, MO | Member Since: 06/16/14 | IP: (2602:306:c5f7:e2) | Report this post to a Moderator

turbohf
anyone even read this?
613/2000


Galant VR-4 org Post #: 1234086 posted 12/08/16 09:41 PM     Remind Me!  Send Private Message   Edit Post      
so, its suppose to snow tonight. so i figured i would test her out real quick before the moment of truth. warmed up a bit, little check threw of mechanicals. drove to get some gas, as im about out of the 3+ month old shit thats been in there. put a couple gallons in, gave her another jumpstart (with spare Nova battery, i really need a jump box for christmas, and probably a couple battery tenders lol). and drove back home.

couple things:
still idle surges with an idle thats little high
yeah, little Honda 151 battery is done. ill have to swing by and get a new one.
big ass difference between driving my Silverado and the Galant lol.
tune seems fine/driveable. just tipped in a little. only 2miles to gas station.


idle is pissing me off. like ~> seriously.



Dustin
1991 GVR4 #613
1966 Chevrolet Chevy II Nova 400 4dr Sedan V8

Posts: 540 | From: Lake Stevens, WA | Member Since: 11/18/11 | IP: (172.76.105.29) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


152/1000


Galant VR-4 org Post #: 1234099 posted 12/09/16 07:34 AM     Remind Me!  Send Private Message   Edit Post      
you know i had the same issue with my JMF and S90, the car wouldn't go lower then 1000-1050 RPMs and the throttle plate was like completely closed. then from time to time it would random idle surge for no reason. like not do it at all that day(3-5 hours of driving) then i come to a stop and it starts to do it. I personally think that had something to do with my ISC wiring possibly going bad, maybe a cracked wire.



138/2000
152/1000

Posts: 3573 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (71.89.204.234) | Report this post to a Moderator

turbohf
anyone even read this?
613/2000


Galant VR-4 org Post #: 1234109 posted 12/09/16 10:06 PM     Remind Me!  Send Private Message   Edit Post   
yeah. im going to try to mess with it some more this weekend. maybe take it over to buddies place for another set of eyes.


bought a new battery today threw work. deals. also drove it to work. as the 2wd silverado with shit ass old nearly bald tires wouldnt do well in even little bit of snow we got. Galant obviously took it like a champ, even sticking to my usual backroad drive. AFR's looked driveable the whole way. tipped in a couple times, looked ok. lit all 4 on some compact snow in 1-2...you know to make sure everything is good


so the little Honda group 151R battery lasted 5 years of abuse at the hands of me, and the galant. letting it sit for long periods, killing it a couple times. dead alternator, etc. not bad for a battery have the size of the OE one that should be there.



Dustin
1991 GVR4 #613
1966 Chevrolet Chevy II Nova 400 4dr Sedan V8

Posts: 540 | From: Lake Stevens, WA | Member Since: 11/18/11 | IP: (172.76.105.29) | Report this post to a Moderator


Pages: 1 | 2 | 3 | 4 | 5 | 6
Previous thread Next thread

Extra information
0 registered and 11 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating: *
Thread views: 16047

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.13 seconds in which 0.072 seconds were spent on a total of 13 queries. Turbo powered.


Hertz's Galant VR-4 Page