The Top Mitsubishi Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Car is sputtering, and barley moves

14of2000

Well-known member
Joined
Aug 12, 2012
Messages
143
Location
Sioux Falls, South Dakota
Hey everyone,

So I am having a pretty crazy issue I have been trying to figure out for the past 2 weeks. So, when I start my car it will run fine for the first 3 or so minutes, It boosts fine and feels great! However, all of a sudden my car starts breaking up and will NOT rev past 2k rpms until I shut the car off and restart it.

So what I have done to figure out whats going on. Replaced my plugs with BPr7es NGK plugs, Newer NGK wires about 4k miles on them, Compression test as follows, 152, 150, 154, 154. Timing is dead on marks on the cam gears and crank line up at 5* base. New denso o2 sensor (just replaced yesterday) and boost leak tested at 20psi, Found some leaks but they are all fixed now.

This all started after I replaced my clutch and flywheel (weird). I really thought this issue was my o2 sensor not cycling, So I replaced the o2 and its finally cycling again. But it has not fixed the issue at all. Any insight would be great. My computer wont link up to my logger so I cant post a log as of now.

Mods are as follows
keydiver chipped ecu, 2g maf, Dejon intake, RC 550cc injectors, Rewired Walbro 255, Bastard 20g.
 

toybreaker

iconoclast
Joined
Apr 30, 2006
Messages
3,581
... last barley move I made cost me some community service /ubbthreads/images/graemlins/devil.gif


What do the spark plugs look like?
(post a pic! /ubbthreads/images/graemlins/smile.gif )

Might be a good idea to check your coil and ignition transistor and their wiring.
 
Last edited:

tektic

Well-known member
Joined
Dec 19, 2012
Messages
1,497
Location
ronkonkoma, ny
this is going to be sensor related. likely maf issue. your going to need to get that logger working to know fore sure.
 

14of2000

Well-known member
Joined
Aug 12, 2012
Messages
143
Location
Sioux Falls, South Dakota
The maf is what I was thinking as well. Hmmmmmm, I do have an extra coil pack I can swap out, i'll see if that does anything and report back with the results. Ill also take a pic of the plugs and post them up when I get home tonight.
 

strokin4dr

Well-known member
Joined
Aug 30, 2005
Messages
2,770
Location
Savannah, GA
Sounds like a bad transistor to me. Suddenly starts to sound like a subaru and doesn't want to rev?? Restarting the engine fixes it temporarily?
Replace it with a known good transistor and make sure that it is bolted to is factory heat sink and not just laying on the intake manifold or hanging there.
 

prove_it

Well-known member
Joined
Jul 3, 2008
Messages
4,201
Location
Sioux Falls, SD
Mike, I got a transistor you can try, also no I don't have a maf. Swing by tonight if your not working.

I still don't get why the O2 sensor fixed it for a day, then it started again. Yes it is an odd issue.
 
Last edited:

transparentdsm

Well-known member
Joined
Jul 27, 2011
Messages
3,690
Location
Cherry Hill, NJ
i didn't understand mine either, i was driving it at like 3000 rpm's and all the sudden i heard a pop and it jumped down to 2000 rpm's a puff of smoke came out from under the hood. i pulled over, turned the car off opened the hood saw the smoke came from the translator pack, unplugged it and plugged it back in, started the car and got to work. once i was at work i pulled the plug again for the day, put dielectric grease on it plugged it back in and made it home. replaced it with another one the following day and never had the problem again.
 

14of2000

Well-known member
Joined
Aug 12, 2012
Messages
143
Location
Sioux Falls, South Dakota
Thanks for all the input so far guys. So I replaced the transistor with another one, and nothing. Still does the same thing. Could it possibly be the coil pack?

Ryan, I'm working tonight unfortunately. But I do have this Friday off so would that work for you?
 

prove_it

Well-known member
Joined
Jul 3, 2008
Messages
4,201
Location
Sioux Falls, SD
sh*t son, I'm always home, lol. I have COP and a coil pack somewhere we can try. Let's throw the COP on, I know for a fact it's fully functional.

Do you still have the GM maf and translator to swap on? Can adjust the main dial on the translator to simulate a 2g sensor.
 

14of2000

Well-known member
Joined
Aug 12, 2012
Messages
143
Location
Sioux Falls, South Dakota
Ya, both of us are always home but it's getting the time away from the little ones to work on our cars thats the problem lol but ok sweet hopefully we can get this figured out soon. Having to share a car suuuuuucks!

But no I sold the maft and maf so I can buy link this Friday woo hoo! Finally lol
 

prove_it

Well-known member
Joined
Jul 3, 2008
Messages
4,201
Location
Sioux Falls, SD
I don't get the O2 issue. It's reading 2.5v again. Also I know your not running 25psi. I think that MAF is off to start.
 

prove_it

Well-known member
Joined
Jul 3, 2008
Messages
4,201
Location
Sioux Falls, SD
What I recall is that the MAP sensor if the MAF sensors reading converted to display pressure. I think?

It's a 2 MAF car. He will go SD once I force him and he gets link set-up.....
 

14of2000

Well-known member
Joined
Aug 12, 2012
Messages
143
Location
Sioux Falls, South Dakota
I actually have dsmlink lite, the map sensor and an iat being shipped to me right now. So the only thing I'm gonna need to run sd will be a wideband, and that will be coming soon as well lol
 
Last edited:
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Recent Classifieds Listings

Top