The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Bad Vibes

tektic

Well-known member
Joined
Dec 19, 2012
Messages
1,499
Location
ronkonkoma, ny
Over 80mph, with 2 different sets of wheels, I get bad vibrations in my car. so much so that my door starts to move... Anyone have any ideas as to what I should check. The same noise or motion isn't evident at any other speeds slower.
 

thomcasey

Well-known member
Joined
Sep 24, 2014
Messages
907
Location
Indianapolis, IN
What carrier bearing bushings are you running. I used to have a vibration/strum because I was using Torque Solution solid bushings. I swapped over to new Outlander bushings, vibration gone.
 

tektic

Well-known member
Joined
Dec 19, 2012
Messages
1,499
Location
ronkonkoma, ny
I guess it could be the rear u-joint or the Lobro. Front is new and shimmed as per book.
Quote:
Outlander bushings


Might you have a part number for these?

The front bolt on the control arm was loose. Good possibility that was the problem. Think my inner tie rod is worn now because of it.
 
Last edited:

Latest posts

Top