The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Recent content by CarRacer

  1. Injectors not firing on BMW E30 4G63 swap, MPI related?

    Well now I don't have 12v at the CAS with KOEO. I give up for tonight. I'll be back at it early next week. Your help in spoon feeding me information is majorly appreciated.
  2. Injectors not firing on BMW E30 4G63 swap, MPI related?

    So...that's the thing. The diagnostic post isn't hooked up in the chassis. I was going to wire it in but that is basically only to get a logger connected but I have no way of writing to a palm pilot with my current PC setup.I'm of the opinion that the CAS is bad.
  3. Injectors not firing on BMW E30 4G63 swap, MPI related?

    When spinning the CAS manually I have no 5v signal at the ECU plug on either pin 21 or 22 with the key on, I can't hear any injectors clicking either. I also checked resistance on the injector resistor pack (I think I had the right ohmmeter settings) and everything measured zero to pin 3. I...
  4. Injectors not firing on BMW E30 4G63 swap, MPI related?

    Maybe the ECU is sh*t? There's slight corrosion behind the eprom chip on the board. The capacitors seem to be in good shape with no acid leaks but I'm not so sure about the rest.
  5. Injectors not firing on BMW E30 4G63 swap, MPI related?

    ECU wire 107 does back trace to the MAF sensor. I'm going to assume that isn't the problem, I'll try spinning the CAS by hand next.
  6. Injectors not firing on BMW E30 4G63 swap, MPI related?

    Yeah, I had a test light hooked up and fired it a couple times on starting fluid to confirm spark. So the CAS is doing something.I'll check that diagram today. I haven't read .org in a while and am glad this place is still cool, very helpful tech info supplied on a picture with a dick drawn...
  7. Injectors not firing on BMW E30 4G63 swap, MPI related?

    The car has been parked for a while, I just put 5 gallons of fresh 92 in it. It had barely any fuel in it so I was able to hear the rail fill. I put a few extra grounds from the motor to the chassis. Coolant sensor is plugged in and wires are in good condition. I'll have to try manually spinning...
  8. Injectors not firing on BMW E30 4G63 swap, MPI related?

    Backstory: Complete motor setup has run in a previous vehicle and I've driven the current car recently. I idled it for a while two weeks ago and the next day it wouldn't start. I have tested and have power to the injector plugs, the injector plug ground wires have continuity to ground, and I...
  9. FS: 2G TB Elbow, Fuel Filter w/ -6 adapter

    With the BMW mostly finished I'm cleaning out the parts stash.SOLD Valve Cover in good shape with no cracks or stripped threads. $60 shipped. SOLD2G throttle body elbow, it has a small piece chipped off on the inlet but it doesn't effect function or performance. $12 shipped.VR4...
  10. FS: NGK wires & Walbro pump

    Selling two brand new NGK plug wires, one marked "1" and the other "2". $20 shipped for the pair.Also selling a used Walbro inline 190 lph pump. $30 shipped.
  11. Not running a thermostat?

    Stopped and got fittings after work today. They didn't have exactly what I wanted but I think what I got will get the job done.Now I'm a little concerned that there doesn't seem like there's any room for water to flow around the sender inside the hex shaped fitting but I think as long as...
  12. Not running a thermostat?

    Amazon sells what I need to retain the sender location in the housing itself, so I'm going to order it if I can't find that part locally.1/2" npt adapter.
  13. Not running a thermostat?

    Yeah, it's an E30 chassis with a 4G63 swap. Here's the build thread.
  14. Not running a thermostat?

    Is a 1/2" long chunk of pipe with a 1/2" npt female on one end and make on the other a thing? Spacing it out sounds like the best solution.
  15. Not running a thermostat?

    No go, I switched to a 1.8l upper thermostat housing so there's a radiator cap in that location.
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned
Top