GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Newbies » New guy
Previous thread Next thread

New guy


Furbasher
Newbie


Galant VR-4 org Post #: 1105494 posted 01/29/13 12:27 PM     Remind Me!  Send Private Message   Edit Post      
Been about 3 years since owning my Laser. Back then I was on a college budget, owned very few tools, and had little to no room to work. I always said I would build a 4g63 the right way someday. Well Hopefully that day has come.

Drove down to Tennessee to pick this thing up. Its a little rough around the edges but I was looking for a project to waste some time with. Unfortunately the badges have been ripped off so I have no Idea what production number it is .

1991 Galant VR-4.

She came equipped with some sort of FP turbo. Full 3" exhaust (which looks brand new) Tial External WG, GM MAF, a few strut tower bars. and I'm sure some other hidden goodies. From what I've found I feel like this car at one point had a good caring owner, who put quality time and work into this car. For whatever reason was sold to a kid who did nothing but F the car.

Loaded on the trailer in the middle of nowhere Tennessee.


Like I said a little rough.




As I was tearing it apart, I found a random wire that had been soldered into an ecu plug. Wait a minute that looks familiar. So I find this.

SCORE!!!


But wait JACKPOT!!!!!


As of right now the car runs and drives, but is getting ZERO boost. With all the janky intercooler clamps I have a feeling it has a serious boost leak. But at the same time the car idles fine and doesnt seem to be hesitant at all. I tried rerouting some vacuum lines with no luck thus far. I haven't put to much time into figuring it out, but if anyone has any ideas.



You're all fur coat and no trousers. You are.

Posts: 16 | From: St. Louis | Member Since: 01/23/13 | IP: (108.78.190.225) | Report this post to a Moderator

spoolin16
Unregistered


Galant VR-4 org Post #: 1105530 posted 01/29/13 03:03 PM     Remind Me!  Send Private Message   Edit Post      
My guess is check boost controller, vacuum lines, and do a boost leak check, prolly where id start.

| | | IP: (166.181.3.164) | Report this post to a Moderator

jnava Galant VR4.org Moderator
Senior Member


Galant VR-4 org Post #: 1105912 posted 01/31/13 11:34 PM     Remind Me!  Send Private Message   Edit Post      
Are you familiar with link, If not the ecmlink wiki will be your best friend and so will some of the vids. Your need to ask for access from the moderators. I think you going to have some fun, you'll also need the v3 cable, which is $56 shipped.



57/2000
1865/2000
1058*/2000-SOLD
1989 Conquest Tsi
2000 2.5Gen Montero
2013 Outlander Sport

Posts: 2065 | From: Arlington, Tx | Member Since: 04/18/08 | IP: (76.184.18.252) | Report this post to a Moderator

Furbasher
Newbie


Galant VR-4 org Post #: 1106050 posted 02/01/13 10:54 PM     Remind Me!  Send Private Message   Edit Post   
Yea I've tuned with v2 Link. Still no pro by any means.



You're all fur coat and no trousers. You are.

Posts: 16 | From: St. Louis | Member Since: 01/23/13 | IP: (108.78.185.186) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 20 anonymous users are browsing this forum.

Galant VR4.org Moderator:  Hertz, curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 1160

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.037 seconds in which 0.026 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page