GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » weird issue - ignition to start, activates fuel pump
Previous thread Next thread

weird issue - ignition to start, activates fuel pump


chrisfullwood
Member +


Galant VR-4 org Post #: 976130 posted 03/11/11 05:00 PM     Remind Me!  Send Private Message   Edit Post      
I just got done rebuilding my car, did alot of work to it, now i have some weird issue.

the first time i hooked the battery back up, i put the key in the on position , the fan came on, as normal, the turbo timer was on showing 0.30 as normal.
everything seemed to be fine.

well then i turned it off, then back on, and it made a weird grinding noise. Turned out it was the ISC making the noise, so i unplugged it. Now, the fan doesnt work, the turbo timer doesnt come on, you cant hear the fuel pump running. When i crank it, all it does it fire up the fuel pump. Thats it.

i cant figure this out. so some help would be awesome.
Thanks
Chris

Posts: 256 | From: bartlesville, ok | Member Since: 04/28/06 | IP: (67.61.85.78) | Report this post to a Moderator

14u2nV
Resident Pedobear


Galant VR-4 org Post #: 976181 posted 03/11/11 09:11 PM     Remind Me!  Send Private Message   Edit Post      
Did your isc fry your ecu?



~Kenneth Brian
"Censorship offends me" ~Author Unknown


Posts: 9397 | From: Agency/St. Joe, MO | Member Since: 07/22/04 | IP: (24.121.148.174) | Report this post to a Moderator

chrisfullwood
Member +


Galant VR-4 org Post #: 976402 posted 03/12/11 10:22 PM     Remind Me!  Send Private Message   Edit Post   
no, turns out i had 2 single post wires in the wrong places. So i swapped them over and things worked. Some of the other issues were, bad grounds, terrible connections in spliced wires. and a popped fuse.

spent the entire day fixing it, and everything seems to be working... i went to fill up the tank with gas, and as the gas pumped... it poured out the hose coming from the gas tank, so i have replaced all kinds of stuff, and ended up with this, stopping me from getting my car on the road.

awesome, Mitsubishi luck strikes again,.

Posts: 256 | From: bartlesville, ok | Member Since: 04/28/06 | IP: (67.61.85.78) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 19 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 2900

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.046 seconds in which 0.037 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page