GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » Speed Density setup
Previous thread Next thread

Speed Density setup


ChandlerFihn
Newbie


Galant VR-4 org Post #: 1211346 posted 07/02/15 11:06 PM     Remind Me!  Send Private Message   Edit Post      
So i am finally at the process of starting up my galant..number 1953/2000..


wiseco 8.5:1 piston
eagle h beams
l19 headtuds
felpro multilayer headgasket
stock head beside kiggly beehive valve springs
fp2 cams
bpr7es
stock cam gears
jmf smim
stock throttle body
tial bov
tial 38mm v band external wastegate off of 02 housing
holset hx40 8 blade
.55 A/r bolt on housing
fp manifold
custom fmic setup
scirroco radiator.
3 inch downpipe
fic 1250s
v3
aromtoive fpr and -6an lines to rail and fpr
fuel lab filter
solid motor mounts
tre stage 3 transmission
southbend clutch
evo coilovers

my question is for those who are running a speed density setup..i set this up on my buddies galant but i seem to be having troubles on my own..
i have ecmlinks plug and play harness and have i think a 4 bar omnipower gm STYLE map sensor..i am getting readings from the map sensor but they are off..at one point it read 20 psi..thats without the car started..should this number not be zero? it is on my buddies galant..the reading from the iat seem normal..i havent gotten the car to actually idle nicely for me yet or really run for that matter..figured this was a good place to start..i have tried changing the setting in v3 to different sensors and the aem3.5 bar sensor seem to get it close to 0..but i am 80 percent sure it isnt a aem sensor..any help would be greatly appreciated

Posts: 10 | From: St Paul MN | Member Since: 02/26/14 | IP: (97.86.113.109) | Report this post to a Moderator

swe_gvr4_1991
Member


Galant VR-4 org Post #: 1211351 posted 07/03/15 04:15 AM     Remind Me!  Send Private Message   Edit Post      
If link shows 0 psi when you select a different sensor than you think you have, then you should trust link since that is what the ECU sees. If you're stubborn and still set a different sensor then all the work will go down the drain.



.. KiM H ..
Galant VR-4 1991. Gulf spec.
Author of Swede Density software - REAL speed density for 1G's and GVR4's - Videos


Edited by swe_gvr4_1991 (07/03/15 07:50 AM)

Posts: 177 | From: Sweden, Alingsås | Member Since: 07/27/06 | IP: (85.228.6.66) | Report this post to a Moderator

prove_it
my racist jokes aren't actually funny
715/1000
1284/2000


Galant VR-4 org Post #: 1211363 posted 07/03/15 09:56 AM     Remind Me!  Send Private Message   Edit Post      
Pics of MAP sensor please.

And yes, your right, the sensor should read 0psi engine off, and around 12-15in vac at idle. You need to get the MAP sensor figured out. Did you mess with wiring at all? Also, where is the MAP line source?

Pics will help the most.



#1284/2K NB, Totaled
#715/1K KG, Rebuilding
02 Acura TL daily duty unit

12yr+ Vr4 owner.
Honda/Acura master tech.
Family Guy

Posts: 4201 | From: Sioux Falls, SD | Member Since: 07/04/08 | IP: (24.230.93.110) | Report this post to a Moderator

ChandlerFihn
Newbie


Galant VR-4 org Post #: 1211397 posted 07/03/15 05:57 PM     Remind Me!  Send Private Message   Edit Post      
it literally is a gm style map sensor that doesnt have any numbers on it..just has abc for the pins..i have the line td into my bov..i know i shouldnt have it td into anything but didnt really have an option..can i run the map sensor off say the p port?

Posts: 10 | From: St Paul MN | Member Since: 02/26/14 | IP: (97.86.113.109) | Report this post to a Moderator

Fiascoxl
Member +
740/1000


Galant VR-4 org Post #: 1211406 posted 07/03/15 09:41 PM     Remind Me!  Send Private Message   Edit Post      
I would use the pcv port for map, I know this requires ousting the pcv set up but the map NEEDS a big clean source.



92 VR4 #740 Nile Black

Posts: 320 | From: Stuarts Draft, Va | Member Since: 01/26/13 | IP: (4.30.227.74) | Report this post to a Moderator

swe_gvr4_1991
Member


Galant VR-4 org Post #: 1211423 posted 07/04/15 04:56 AM     Remind Me!  Send Private Message   Edit Post      
Never use the P-port since it has inherent lag. Also don't use the blow off valve line.
Use the FPR nipple or PCV. Most users use the FPR port and it has a nice response time.

You can always test for 0 point on your MAP sensor by hooking it up to a 5 volt source and measure the voltage with the nipple fed by free air. That way you can find what sensor you have easily when looking in data sheets etc. The raw ADC value of 0 PSI (gauge) on a 3 bar MAP sensor is 82 at the ECU side. I don't know if link can display raw data. But this is about 1.61 volts.



.. KiM H ..
Galant VR-4 1991. Gulf spec.
Author of Swede Density software - REAL speed density for 1G's and GVR4's - Videos


Edited by swe_gvr4_1991 (07/04/15 04:57 AM)

Posts: 177 | From: Sweden, Alingsås | Member Since: 07/27/06 | IP: (85.228.6.66) | Report this post to a Moderator

prove_it
my racist jokes aren't actually funny
715/1000
1284/2000


Galant VR-4 org Post #: 1211549 posted 07/06/15 10:22 AM     Remind Me!  Send Private Message   Edit Post   
Quoting ChandlerFihn:

it literally is a gm style map sensor that doesnt have any numbers on it..just has abc for the pins..i have the line td into my bov..i know i shouldnt have it td into anything but didnt really have an option..can i run the map sensor off say the p port?





You said in your first post that you THINK you have an omnipower 4 bar sensor. Think and know are two different things. GM map sensors look alike but have different ranges and you might have the wrong one. I'm curious as to why you THINK you have the right one.



#1284/2K NB, Totaled
#715/1K KG, Rebuilding
02 Acura TL daily duty unit

12yr+ Vr4 owner.
Honda/Acura master tech.
Family Guy

Posts: 4201 | From: Sioux Falls, SD | Member Since: 07/04/08 | IP: (24.230.93.110) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 16 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 1915

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.063 seconds in which 0.045 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page