GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » Power steering issue
Previous thread Next thread

Power steering issue


Gtpdz
Member
594/1000


Galant VR-4 org Post #: 1209443 posted 06/03/15 11:45 AM     Remind Me!  Send Private Message   Edit Post      
Has any one have a similar issue where the power steering only works when turning the steering wheel to one side?

Posts: 140 | From: Gig Harbor, WA | Member Since: 03/12/15 | IP: (2601:4:1d81:8800) | Report this post to a Moderator

thomcasey
I ain't no puny human
866/1000


Galant VR-4 org Post #: 1209447 posted 06/03/15 01:15 PM     Remind Me!  Send Private Message   Edit Post      
I have seen it where it will absolutely not move in one direction temporarily but never fails when the PS pump is disabled. But, what you are describing is a definite Rack issue as the PS pump doesn't care what direction you turn.



Thom
866/1000 (PTE 1200's, billet 20g+, DSMLink v3, eagle/ross, .020 over, 272's, GC/AGX Coilovers)

Posts: 905 | From: Indianapolis, IN | Member Since: 09/24/14 | IP: (50.58.165.200) | Report this post to a Moderator

Gtpdz
Member
594/1000


Galant VR-4 org Post #: 1209456 posted 06/03/15 03:26 PM     Remind Me!  Send Private Message   Edit Post      
Thanks, that's what I have been wondering about, will try to swap in a different one and see how it does.

Posts: 140 | From: Gig Harbor, WA | Member Since: 03/12/15 | IP: (2601:4:1d81:8800) | Report this post to a Moderator

toybreaker Galant VR4.org Moderator
it's peace of mind at 100 mph plus
1990/2000


Galant VR-4 org Post #: 1209459 posted 06/03/15 05:29 PM     Remind Me!  Send Private Message   Edit Post      
Before tearing into it, I would eyeball all the external lines

A kinked / restricted external crossfeed line (external to the rack) can cause this.


Does this vehicle still have aws?

It's *possible* that damage to one of the feed lines to the rear rack could also cause this problem on an aws equipped vehicle.



If all the external stuff looks good, it may be a damaged spool valve (internal to the rack)

Posts: 3541 | From: Never Summer Ranch, Colorado | Member Since: 04/30/06 | IP: (70.196.208.43) | Report this post to a Moderator

Gtpdz
Member
594/1000


Galant VR-4 org Post #: 1209463 posted 06/03/15 05:55 PM     Remind Me!  Send Private Message   Edit Post      
the vehicle still have all the 4WS device and line hooked up, Iam not sure if it works, is there a way to check that? although no visible leak outside though.

Posts: 140 | From: Gig Harbor, WA | Member Since: 03/12/15 | IP: (166.137.90.24) | Report this post to a Moderator

dsm1990tsi
Newbie


Galant VR-4 org Post #: 1210234 posted 06/15/15 05:37 PM     Remind Me!  Send Private Message   Edit Post      
I would think the rack has an internal problem. Also check the steering shaft and make sure that moves freely.

Posts: 17 | From: Pottstown, Pa | Member Since: 08/09/08 | IP: (66.87.83.168) | Report this post to a Moderator

Gtpdz
Member
594/1000


Galant VR-4 org Post #: 1210240 posted 06/15/15 07:57 PM     Remind Me!  Send Private Message   Edit Post      
I would say the shaft moves pretty smooth, once the car is moving turning is much easier.

Posts: 140 | From: Gig Harbor, WA | Member Since: 03/12/15 | IP: (2601:40d:c001:1c) | Report this post to a Moderator

Gtpdz
Member
594/1000


Galant VR-4 org Post #: 1218479 posted 10/13/15 05:46 PM     Remind Me!  Send Private Message   Edit Post   
Finally taking a look at this issue, looks like the rack has been rebuilt before with Koyo steering gear, however one external cross feed line that goes into the left chamber was crushed (car once bottomed judging by the dent on the down pipe below). So I guess that's the reason here as the car has very little ps when turning left.

Will try replacing this line with the rack on the car and see if it goes away.

Posts: 140 | From: Gig Harbor, WA | Member Since: 03/12/15 | IP: (68.40.62.254) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
2 registered and 14 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 2035

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.054 seconds in which 0.042 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page