GalantVR4.org The Mitsubishi Galant VR-4 Forum
NOTICE: This forum is for archiving information and discussions. Please do not reply to threads unless you have valuable information to add. Do not post questions or problems here.

Galant VR-4 Forums » Galant VR-4 » How To and Info Archive » Help! Sony Clie Datalogger cable Question
Previous thread Next thread

Help! Sony Clie Datalogger cable Question


GalantVR4-1229
Unregistered


Galant VR-4 org Post #: 267501 posted 10/15/05 05:00 PM     Remind Me!  Send Private Message   Edit Post      
I just got my Sony Clie N760C and eBay serial cable.

I've got a Jeff O. "Special ECU" with a datalog serial cable built in. It works great with my laptop.

I tried to use it with my Palm and it doesnt work. First problem was that both connectors are Male. I fixed that with a gender changer. After I got that, it still doesnt work.

So I started to investigate this..

I looked at the connector Jeff gave me. It's a phone cord with a RS-232 connector on the end. I opened it up and found the 4 wires.

The pin out is as follows:
2 Red
3 Black
4 Green/Yellow

I know from the RS232 pin out below that pin 2 is RxD and 3 is TxD. 4 is GND.

Then...

I've found the pin out's for the connector on the palm here:

http://www.pspilot.de/ppp760/ppp760.html

The only pins I think I need are

4 RxD
6 TxD
12 CNT
13 GND

I've verified that the palm cable has 47 KOhm's between pin's 12 and 13. So the Palm should know it should use serial and not USB.

I looked up the pin outs for a typical RS-232 cable here:

http://www.aggsoft.com/rs232-pinout-cable/pinout-and-signal.htm

The only pins I think I need are
2 RxD
3 TxD
5 GND

So based on this info..
I cut a phone cord and striped the ends, and connected it all together. I've got my trusty volt meter here testing connectivity.

The red phone wire should end up on pin 4 of the palm connector
The Black phone wire should end up on pin 6 of the palm connector
Green and yellow should end up on pin 13 on the palm connector.

Red(RxD) -> pin 4 RxD
Black (TxD) -> pin 6 TxD
Green/Black (GND) -> pin 13 GND.


When I actually test this the RxD and TxD are backwards. In other words,

Red (Rxd) -> pin 6 TxD
Black (TxD) - pin 4 RxD

So is this my problem? Do I just need to swap the pins?

Justin

| | | IP: (68.57.48.138) | Report this post to a Moderator

GalantVR4-1229
Unregistered


Galant VR-4 org Post #: 267509 posted 10/15/05 05:19 PM     Remind Me!  Send Private Message   Edit Post      
In addition, I've foudn this:
http://www.gpsinformation.org/dale/Palm/phardware.htm

Device connector to 9-DB wiring
4 <-- RxD 3 Txd
5 --> RTS 8 CTS
6 --> TxD 2 RxD
7 <-- CTS 7 RTS
12 <- CNT 47K ohm resistor tied to pin 13 (GND)
13 -- GND 5 GND

I only need this
Device connector to 9-DB wiring
4 <-- RxD 3 Txd
6 --> TxD 2 RxD
12 <- CNT 47K ohm resistor tied to pin 13 (GND)
13 -- GND 5 GND

Which means I dont need to swap the pins?

I'm so confused.

This site:
http://www.mulliner.org/palm/clie.html

Says
If you look into Sony's specs of the Clié (www.us.sonypdadev.com) you see that you need 1.0V on pin 12 of the device to activate the serial port hardware. If you check the pin you see that the port supplies about 2.5V so we just connect a resistor to it and the ground (GND pin 13).

So does that mean I need to supply pin 12 with 1 volt in order to get the Serial hardware active?

Maybe I should just buy a serial cable from POcketLogger...

| | | IP: (68.57.48.138) | Report this post to a Moderator

DarkDevilMMM
if I want a potential headache, I rather just get another GVR4
335/1000


Galant VR-4 org Post #: 267525 posted 10/15/05 06:15 PM     Remind Me!  Send Private Message   Edit Post      
I am confused about what you trying to say, sorry, so many words and so many pin numbers....

ok, but here's what I know about sony clie and datalogger.

1, There are couple clie model serial port doesn't work, although they have it built in, but still doesn't work, only USB
2, clie serial port is 3.3V compare to most palm is 5V, this only applies if you connect anything directly to the clie, there is still a chance the conversion in the cable isn't done right
3, a lot of clie serial cable sold on e-bay doesn't work, refer to (1) and (2)
4, make sure the clie + serial cable work on computer(hotsync) before putting on the car, frying the serial port is kind of hard, but frying the ECU is easy
5, pocketlogger cable won't do you any good since clie is pain in the ass to start with

however I did designed a cable for clie N, NV, T series, which can do charging and datalogging at the same time, but I just didn't have time to get around building and testing it, anyways, have fun



huh?

Posts: 4065 | From: Vacaville, CA | Member Since: 06/08/01 | IP: (69.108.0.97) | Report this post to a Moderator

HHIVR4
Aluminum Lung
1280/2000
138/2000



Galant VR-4 org Post #: 267562 posted 10/15/05 08:37 PM     Remind Me!  Send Private Message   Edit Post      
You probably need a null modem

Posts: 5446 | From: Hilton Head Island SC | Member Since: 10/06/03 | IP: (206.74.64.190) | Report this post to a Moderator

Yiuwa
Right-hand Member


Galant VR-4 org Post #: 267570 posted 10/15/05 09:12 PM     Remind Me!  Send Private Message   Edit Post      
Check this and see if you wire them up like this:

Datalogging cable circuit diagram from archive


Edited by Yiuwa (10/15/05 09:13 PM)

Posts: 641 | From: Pokfulam, Hong Kong | Member Since: 08/10/03 | IP: (203.218.214.117) | Report this post to a Moderator

GalantVR4-1229
Unregistered


Galant VR-4 org Post #: 267640 posted 10/16/05 08:11 AM     Remind Me!  Send Private Message   Edit Post      
Looks like the only difference between those two cables is pins 2 and 3 are swapped. I think thats what I need to do.

I'll wait and see if Jeff chimes in.

| | | IP: (68.57.48.138) | Report this post to a Moderator

GalantVR4-1229
Unregistered


Galant VR-4 org Post #: 267650 posted 10/16/05 08:39 AM     Remind Me!  Send Private Message   Edit Post      
Looks like a null modem cable swaps those pins. I'll try one.

| | | IP: (68.57.48.138) | Report this post to a Moderator

GalantVR4-1229
Unregistered


Galant VR-4 org Post #: 267666 posted 10/16/05 10:29 AM     Remind Me!  Send Private Message   Edit Post   
Quote:

You probably need a null modem




Null modem cable for teh win!

Works great.


| | | IP: (68.57.48.138) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 4 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 6644

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.078 seconds in which 0.043 seconds were spent on a total of 14 queries. Turbo powered.



Hertz's Galant VR-4 Page