The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Starter/ECU/MPI wiring

CarRacer

Well-known member
Joined
Jun 28, 2007
Messages
4,371
Location
Shakopee, MN
I'm wiring up my motor swap project and it's been years since I figured this all out for the Chevette. I forgot how it was wired up and I'm reaching a dead end in my googling so I'm hoping you guys can help.




I'm trying to figure out what pin 110 and 108 are. I'm pretty sure I run 102 to switched 12v and 13 to constant 12v, I completely forget what 108 and 110 got wired to in the Chevette.


Edited to add: Discovered Pin 2 on my MPI relay and Pin 10 on the MPI relay were cut and have non-factory wire connectors on them in this harness. Where should these wires go in the factory configuration? The best answer I found is that Pin 10 gets constant 12v power and Pin 2 triggers the fuel pump. I'm not sure if Pin 2 should go to the rewire relay or what though.
 
Last edited:

Spyke169

Well-known member
Joined
Aug 17, 2005
Messages
324
Location
Greenfield, Wi
90-91EL-73.jpg


If you have a factory service manual, it is on page 8-73 of the 90-91 Volume 2 Electrical.
 

CarRacer

Well-known member
Joined
Jun 28, 2007
Messages
4,371
Location
Shakopee, MN
I saw that but I don't read schematics very well and all I got out of it is that one wire is involved with the fuel pump and the other is involved with power. I wasn't able to determine where the wires should actually go.

Your link is helpful, I'm not just able to utilize it.
 

CarRacer

Well-known member
Joined
Jun 28, 2007
Messages
4,371
Location
Shakopee, MN
Yeah, that was the best post explaining things. I'm starting to remember how I had it wired, I believe one is my fuel pump signal that I ran to there wire relay. The other wire I'm just going to run to constant 12v, pretty sure that'll be correct.
 

GSTwithPSI

Well-known member
Joined
Jan 1, 2012
Messages
3,446
Location
SoCal
Make sure the wire on pin 108 is connected somewhere between the starter relay and the MPI control relay on pin 9. The ECU should see 12v on pin 108 when the key is turned to the start position (when cranking).
images
on

Pin 110 goes to the ignition switch. Looking at the diagram, it looks like it connects in at the 6 pin connector (C-59). I believe it would be your 12v constant when the ignition is in the run position. I'd guess that connector would normally be under the dash, but I'm not sure. I can't seem to find a locator anywhere in the manual.

Both of these wires should run directly from the ECU to their respective places in the harness, as outlined above.
 

CarRacer

Well-known member
Joined
Jun 28, 2007
Messages
4,371
Location
Shakopee, MN
Okay, sweet. The key position/wire power state information was super helpful. The problem is that I won't be connecting the wires to a factory harness, so simply tracing the wires on the diagram didn't get me very far.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Recent Classifieds Listings

Top