The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Radiator Fan Fuse keeps blowing

ihugzombies

Active member
Joined
Aug 29, 2019
Messages
40
Location
Los Angeles, CA
I just finished wiring up my 12inch puller fan and running it successfully however the fuse blew. Pins 1-6 (resistor) are together, 2-5 are to the thermosensor and 4-6 are to the spal. I replaced the fuse and ran both fans SPAL puller and stock A/C pusher and the fuse blew again. Tested the voltage to the fuse and its making 26volts. It should be 12v correct? I tested another part of the car and saw it was also pulling double than the recommended voltage.

Is there an issue with the grounding of my car then?
 

JNR

Well-known member
Joined
Apr 23, 2004
Messages
9,802
Location
ca
Are you sure the meter is set on DC and not AC voltage?

As for blowing fuses, check for a short somewhere...especially on those areas where you ran the wire to be sure it didn't get chaffed, squished or otherwise exposed (where it can ground/short).

[EDIT - does it blow the fuse right away, or after it runs? Start-up of an electric motor, namely the fan, generally requires a lot of amperage. Are you sure the fuse is proper rating?]
 
Last edited:
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Top