The Top Mitsubishi Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Normal for the cruise control to surge?

cupajoe

Well-known member
Joined
Mar 1, 2010
Messages
343
Location
Cocoa, FL
I plan on doing the cruise control delete anyhow but was wondering if its normal for the cruise control to surge? Cruise doesnt help my gas mileage because it drops ~5mpg then goes back to set mph then drops again and rises. This causes me to go into boost more often and the reason I don't use cruise. Is this normal or an easy fix?
 

Barnes

Well-known member
Joined
Feb 9, 2003
Messages
6,249
Location
Richland, WA
It is very common on modded cars. It works perfect on stock cars, in my experience anyways.
 

cupajoe

Well-known member
Joined
Mar 1, 2010
Messages
343
Location
Cocoa, FL
When I got my car is was completly stock other then built trans and clutch and it was surging. Anyone have a good working cruise control on their built car?
 

Diego

Well-known member
Joined
Dec 9, 2007
Messages
2,132
Location
In a van down by the river, Iowa
My car is not "built" but has respectable mods... I need i to update my list in the profile, but I have used cruise a few times and it was fine for me /ubbthreads/images/graemlins/dunno.gif


Cruise in 577 with minor mods, drives just fine with cruise too
 

Muskrat

Well-known member
Joined
Jun 13, 2004
Messages
2,107
Location
Lexington, KY
Surged on my car as well, before I removed it. It was basically stock.

It's an early, 20-year-old system. Somethings bound to have deteriorated. Just another reason to remove it on a modded car and get MUCH better throttle response.
 

cupajoe

Well-known member
Joined
Mar 1, 2010
Messages
343
Location
Cocoa, FL
I must have a bad unit, guess its time to do the cruise delete /ubbthreads/images/graemlins/smile.gif
 

I think it comes from the fact that the cruise is vacuum actuated and it is built with the stock boost levels in mind, and when you crank the boost up it destroys the system. Mine surges like crazy too.....
 

Yeah I like having cruise, but even in my 2g gsx it surged and it was only slightly modded, stock turbo. Flat ground it was fine, but when it started climbing it seemed like it was giving it more throttle to compensate than it needed.
 

My 2g gsx does this also. So far, no issues like that with 1947. Of course I don't use it that much.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Recent Classifieds Listings

Top