The Top Mitsubishi Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Help! Car tries to start, but won't run.

AWDPower

Well-known member
Joined
Feb 28, 2011
Messages
107
Location
Vacaville, CA
Help me out guys. My car fires right up when I turn the key, but dies immeditately. It climbs to 1000rpm and dies. Very similar to what happens when you pull the fuse to the fuel pump. It seems to be getting fuel, I even got a small back fire after a few tries to start it. I did try cranking with the fuel pump unplugged in case it was flooded. I had a pinhole in the upper radiator hose this morning. No overheat, but it steamed the engine compartment. I'm sure it's related, but where should I look? CAS? The car ran fine after I fixed the leak half way to work. It's been sitting for about 6 hrs.

Thank you.
 

AWDPower

Well-known member
Joined
Feb 28, 2011
Messages
107
Location
Vacaville, CA
Okay, tried to start it a couple more times. Now it doesn't fire at all, and the tach stays at zero. Does that point to the CAS?
 

G

Staff member
Joined
Feb 24, 2004
Messages
8,896
Location
zompton
Ecu for sure.
 

AWDPower

Well-known member
Joined
Feb 28, 2011
Messages
107
Location
Vacaville, CA
It was getting fuel and spark at first, but only briefly when I first turned the key. After a few tries to start, fuel (and I believe spark, but need to verify) went away, and the tach stopped working. I checked the T-belt, it was fine. The engine turns over normally. It did start and idle rough when cold this morning, something it did a couple times last winter. It was foggy for the first tine this morning. I'm sure the steam bath from the radiator hose leak made the problem worse. The caps have been changed in the ECU. I had to leave the car at work, I think I have a spare CAS that I can try tomorrow.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Recent Classifieds Listings

Top