The Top Mitsubishi Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Electrical gurus!!! Car turns over but wont catch.

Boostin21

Well-known member
Joined
Nov 24, 2004
Messages
1,173
Location
Wisconsin, USA
Ok so at first all the lights worked minus the headlights(no/bad bulbs). Then they dint work. I traced all my grounds and fixed 2 in the engine bay. Lights work. Now i'm back to no working lights. only brake lights work, dash lights are out, tails and indicators.
AND...
I turned the car over to check for leaks. After i took care of the leaks, i go to crank her over and let her run, set fuel trims and pressure, check CAS timing, yada, yada.

It wont catch...
i charge the battery...
Still wont catch...

I am running an odyssey pc680.
With the key in the on position, a multimeter reads 12.5-12.7v. During cranking, the meter reads 7.9-8.4v... I thought that batteries were junk if they went under 10v during cranking/run time?

Help me!
 

Hertz

Staff member
Joined
Jul 29, 2002
Messages
13,501
Location
Chicago, IL
Does it crank and not fire? Or does the starter spin and not engage? Does the tach move when cranking?
 

ktmrider

Well-known member
Joined
Sep 10, 2007
Messages
3,128
Location
Tempe, AZ
I can tell you this much, most 12v electrical relays will NOT toggle with less than 10v at the coil.
You should not see the voltage drop that much. Check your grounds again, usually the biggest culprit and the cables running to the starter ( poor connections or high resistance ).
 

Boostin21

Well-known member
Joined
Nov 24, 2004
Messages
1,173
Location
Wisconsin, USA
its tough with one ground as the battery is directly behind the pass headlight. so it is grounded very well to the chassis there thats the one right off the neg. post.

the engine turns and turns and turns, i have fuel but i am not 100% sure if there is spark. i am trying to locate a stock coil pack to borrow and check it out (im using COP).

i have one ground on the chassis by the battery.
one on the trans, should be on the block but wont reach.
the one on the starter and i cant think of the other ones off the top of my head.
i think there should be a ground going to the firewall off the backside of the motor but i cant remember. but its not there.

i am el terrible at wiring and electrical diagnostics so please forgive me.
 

even with my running car the stock ground cable isnt enough. I ran 2 4gage off the negative to add as more grounds. It did help out for sure. More grounds the better. I run a optima yellow top, the new smaller style. It sounds like your short on grounds. The one that you say wont reach is a must. Basicly you need every ground on these cars plus some.
 

Hertz

Staff member
Joined
Jul 29, 2002
Messages
13,501
Location
Chicago, IL
Quoting ktmrider:
I can tell you this much, most 12v electrical relays will NOT toggle with less than 10v at the coil.
You should not see the voltage drop that much. Check your grounds again, usually the biggest culprit and the cables running to the starter ( poor connections or high resistance ).



Just talking to Terry about this, he says the ECU won't work with the voltage that low.

I wonder if you have a bad cell/battery dead.
 

Boostin21

Well-known member
Joined
Nov 24, 2004
Messages
1,173
Location
Wisconsin, USA
well it fired up!

i added 2 grounds and my buddy checked power by the ecu, i went to crank it to check the ecu and all of a sudden it wanted to go. we cranked and she runs!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

now heres the other story...
still no power to the headlights. power is at the fuse box in the engine bay and all grounds are good.
tach is not registering either.

no leaks. so i got that going for me... which is nice.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Recent Classifieds Listings

Top