GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » 2G MAF issue
Previous thread Next thread

2G MAF issue


GTX
Member


Galant VR-4 org Post #: 1229799 posted 06/28/16 08:57 AM     Remind Me!  Send Private Message   Edit Post   
Hi gurus,

Just wanted to pick your brains, may be someone had similar issue. The engine quit on a very hot day (well, we were running it quite hard to be honest). Symptoms of running on 3 cylinders, but with no power whatsoever. It appeared to be a MAF supplying twice as much frequency to ECU. Say, instead of 50-60 Hz at 1200 RPM it would tell 150 Hz. Engine was running too rich. Disconnecting the MAF fixed the idle (ECU goes into default mode), obviously MAF has to be replaced. However, has anyone of you played with MAF internals? I mean the board itself, may be it has some known weaknesses? Capacitors, not heat-sink for the transistors and etc?

Cheers
A



1991 Galant VR4 RS Rally
2005 Subaru RS 2.5
2013 Honda Accord EX V6
2017 Honda Ridgeline EX

Posts: 93 | From: Toronto, Canada | Member Since: 04/13/12 | IP: (108.168.26.208) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 8 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 923

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.196 seconds in which 0.189 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page