GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Newbies » adding walbro and evo 560's with 16g
Previous thread Next thread

adding walbro and evo 560's with 16g


Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1079797 posted 08/07/12 09:27 PM     Remind Me!  Send Private Message   Edit Post      
hi guys ive my gvr4 for about 9 months only been drivable 3, but i just did the timing belt and got it running running again, but i noticed it had pretty much no power over 4000 and putted but i hear the boost swoosh,no boost gauge tho but after all the bars are lit on dash it keeps getting louder. so i found out that i have the evo 3 big 16 i forgot the numbers but it had 47 between the numbers that stick out. ohter mods are bc cams stage 1 im told, 2 1/2 to 3 inch turbo back. my queston is i just bought evo 560 injectors and a walbro 255 with re wire kit and will adding those with out some fuel controll like apexi s-afc make it more driveable in the mid range and stop what i think is fuel cut or pulling timing? maybe one or the other untill i get the s-afc??? thanks for all help.



1991 #1415/2000 SOLD


Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

LIV4PSI
dyslexic 1051
1501/2000


Galant VR-4 org Post #: 1079801 posted 08/07/12 09:46 PM     Remind Me!  Send Private Message   Edit Post      
The big question is what is being used for boost control? A boost gauge is basically the first mod you should do. Buy one, and find out what boost you are running.



-Craig
1501 Build Thread


Posts: 1762 | From: O-H-I-O | Member Since: 11/24/11 | IP: (151.213.64.25) | Report this post to a Moderator

mtbmafia
Newbie
360/2000


Galant VR-4 org Post #: 1079804 posted 08/07/12 10:07 PM     Remind Me!  Send Private Message   Edit Post      
I'm running an EVO 3 16g and 560 injectors with a walbro 255 right now with no air fuel controller (have DSMlink on the way). My car runs suprising well as it sits. I've also got a 2g MAF which I was running with the injectors before I got the 16g installed. Do you know if you're still running the stock MAF?

Posts: 12 | From: Helena, MT | Member Since: 08/03/11 | IP: (66.113.51.135) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1079812 posted 08/07/12 10:44 PM     Remind Me!  Send Private Message   Edit Post      
im pretty sure it is stock MAF, how can i tell if it is 2g?



1991 #1415/2000 SOLD


Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

mtbmafia
Newbie
360/2000


Galant VR-4 org Post #: 1079850 posted 08/08/12 07:46 AM     Remind Me!  Send Private Message   Edit Post      
Is the air filter in the stock location? If so it's probably not a 2G Also, the 2G MAF will have the number 609 on top of it if you have one. If you don't have a 2g I'd look at picking one up from someone for cheap. They're usually for sale on here and iceman69510 makes adapters to plug into the stock wiring. There are some good threads on installation lurking around here as well.

Posts: 12 | From: Helena, MT | Member Since: 08/03/11 | IP: (66.113.51.135) | Report this post to a Moderator

Jason G.
Bourne Employment Supremacy


Galant VR-4 org Post #: 1079860 posted 08/08/12 08:53 AM     Remind Me!  Send Private Message   Edit Post      
It likely won't make your situation better. You really need some way to control the larger injectors, either chip ,safc or link. Not that it isn't a good idea to upgrade the fuel pump though. Especially with larger injectors.

Do some searching on the visual differences of MAFs, it's very easy to identify.

Posts: 3279 | From: Anderson, SC | Member Since: 10/07/03 | IP: (149.55.30.100) | Report this post to a Moderator

LIV4PSI
dyslexic 1051
1501/2000


Galant VR-4 org Post #: 1079861 posted 08/08/12 09:00 AM     Remind Me!  Send Private Message   Edit Post      
His injectors aren't installed yet, they aren't the issue. It sounds like fuel cut from too much boost to me. The OP still hasn't answered what is going on in the boost control department.

And both the injectors and MAF will need tuned for, and just tossing them in there won't help anything. Did I mention you need a boost gauge?



-Craig
1501 Build Thread



Edited by LIV4PSI (08/08/12 09:14 AM)

Posts: 1762 | From: O-H-I-O | Member Since: 11/24/11 | IP: (151.213.64.25) | Report this post to a Moderator

Barnes
Firechicken
908/1000
237/2000


Galant VR-4 org Post #: 1079879 posted 08/08/12 10:33 AM     Remind Me!  Send Private Message   Edit Post      
+1 on getting a boost gauge

Also, it might help if you send us a pic of your engine compartment. Also, what kind of boost control is your turbo hooked up to?



-Jon Barnes
#580/2000 (Long Gone)
#908/1000 Black (Sold)
#237/2000 White

Posts: 6249 | From: Richland, WA | Member Since: 02/09/03 | IP: (198.232.211.130) | Report this post to a Moderator

Jason G.
Bourne Employment Supremacy


Galant VR-4 org Post #: 1079880 posted 08/08/12 10:33 AM     Remind Me!  Send Private Message   Edit Post      
Quote:

His injectors aren't installed yet, they aren't the issue




I was answering this question;


Quoting Gvr41415:

my queston is i just bought evo 560 injectors and a walbro 255 with re wire kit and will adding those with out some fuel controll like apexi s-afc make it more driveable in the mid range and stop




Edited by Jason G. (08/08/12 11:06 AM)

Posts: 3279 | From: Anderson, SC | Member Since: 10/07/03 | IP: (149.55.30.100) | Report this post to a Moderator

Barnes
Firechicken
908/1000
237/2000


Galant VR-4 org Post #: 1079881 posted 08/08/12 10:51 AM     Remind Me!  Send Private Message   Edit Post      
Actually, let me take a step back. Whatever you do, don't put more mods on it. Let's figure out what you have, what condition it's in, and why it's not working FIRST. Then, if needed or desired, you can continue with mods.

We need to establish exactly what parts you have on your car, and how they are functioning. For example:

Exactly what MAF you have.
What ECU you have.
How your boost control is setup.
How much boost you are running.



-Jon Barnes
#580/2000 (Long Gone)
#908/1000 Black (Sold)
#237/2000 White

Posts: 6249 | From: Richland, WA | Member Since: 02/09/03 | IP: (198.232.211.130) | Report this post to a Moderator

LIV4PSI
dyslexic 1051
1501/2000


Galant VR-4 org Post #: 1079882 posted 08/08/12 10:51 AM     Remind Me!  Send Private Message   Edit Post      
Jason, you are correct sir, I am an idiot. I'm still waiting for my coffee to kick in.

OP, I have a couple cheap boost gauges laying around. One is a Faze, and one is a Sunpro. $20 and $10 shipped respectively to a fellow .org member.



-Craig
1501 Build Thread



Edited by LIV4PSI (08/08/12 10:52 AM)

Posts: 1762 | From: O-H-I-O | Member Since: 11/24/11 | IP: (151.213.64.25) | Report this post to a Moderator

Dark_Horse
Member +
455/1000


Galant VR-4 org Post #: 1079902 posted 08/08/12 12:34 PM     Remind Me!  Send Private Message   Edit Post      
Quoting mtbmafia:

If you don't have a 2g I'd look at picking one up from someone for cheap.




Running a 2G MAF requires modifying the intake pipe to make it fit. If you run an EVO8 MAF, it fits the stock intake pipe without any modification.

Not to mention that the EVO8 MAF works better and can read higher HZ than the 2G one.

Posts: 303 | From: Morrison, CO | Member Since: 09/06/10 | IP: (192.208.19.7) | Report this post to a Moderator

matt92vr4
Member ++
474/1000


Galant VR-4 org Post #: 1079905 posted 08/08/12 12:49 PM     Remind Me!  Send Private Message   Edit Post      
There is something wrong. Don't throw more parts at it until you diag the current issues. Your description does not sound like fuel cut to me. It sounds like boost/intake leaks causing the car to stumble. If you are hitting fuel cut the car would run strong and powerful at 4k and then have a violent power loss up higher. Could also be fouled plugs from running too rich due to the walbro pump that is already in the tank from the previous owner (same guy who snuck that 16g in there and never tuned it).

Check for boost/intake leaks both before and after the MAF. Inspect the pump and injectors. They might already be aftermarket.



474/1000 Summit White
1993 Stealth RT/TT
1995 Montero SR
1998 Montero

Posts: 676 | From: Venice, FL | Member Since: 10/03/10 | IP: (68.34.158.83) | Report this post to a Moderator

mitsuturbo
Banthony
555/1000


Galant VR-4 org Post #: 1079939 posted 08/08/12 03:54 PM     Remind Me!  Send Private Message   Edit Post      
Quoting Gvr41415:

hi guys ive my gvr4 for about 9 months only been drivable 3




Welcome to Galant VR4 ownership! You'll get used to it.



92 GVR4 555/1000 11.41 @ 128.26mph
97 CBR900RR
2012 Hyundai Veloster

Posts: 3537 | From: Near Seattle, Washington | Member Since: 06/02/08 | IP: (50.54.255.35) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1080094 posted 08/09/12 09:32 PM     Remind Me!  Send Private Message   Edit Post      
the injectors are blue tops



1991 #1415/2000 SOLD


Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1080097 posted 08/09/12 09:51 PM     Remind Me!  Send Private Message   Edit Post      
just added a boost gauge teed in right out the fitting in compressor outlet. what i know is it has stock ecm, stock maf, stock blue top injectors and pump but not sure about pump, stage 1 bc cams, 2 1/2 turbo back with 3in cat, and 16g. the boost hits 7psi @ 3500-4000rpm then loud putt-put-put (almost like launch control) no power right when i hear loud spool, shift up boost gauge jumps to 10-11psi. going to pressure leak the intake side 2morrow.


i tapped into this hose for boost gauge\/












1991 #1415/2000 SOLD


Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1080098 posted 08/09/12 09:58 PM     Remind Me!  Send Private Message   Edit Post      
not letting me add pics.

Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1080100 posted 08/09/12 10:07 PM     Remind Me!  Send Private Message   Edit Post      


















1991 #1415/2000 SOLD


Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

Jason G.
Bourne Employment Supremacy


Galant VR-4 org Post #: 1080101 posted 08/09/12 10:07 PM     Remind Me!  Send Private Message   Edit Post      
Tap into the vacuum line at the fuel pressure regulator. It's much closer than routing it around the engine.

Get a boost leak test done. A bit early for cam upgrades.

Posts: 3279 | From: Anderson, SC | Member Since: 10/07/03 | IP: (99.63.228.144) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1080102 posted 08/09/12 10:21 PM     Remind Me!  Send Private Message   Edit Post      
oh yea looks like no boost controller either



1991 #1415/2000 SOLD


Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1080242 posted 08/10/12 08:35 PM     Remind Me!  Send Private Message   Edit Post      
you were right, i boost leak tested it and sure enough heard a loud hissing near my ear coming the turbo outlet to inter cooler pipe. now my car hits 15psi @5500-6000rpm.



1991 #1415/2000 SOLD


Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

matt92vr4
Member ++
474/1000


Galant VR-4 org Post #: 1080248 posted 08/10/12 09:00 PM     Remind Me!  Send Private Message   Edit Post      
sounds like you are on the right track. It should hit 15psi before that though. Does it at least run smooth to redline?



474/1000 Summit White
1993 Stealth RT/TT
1995 Montero SR
1998 Montero

Posts: 676 | From: Venice, FL | Member Since: 10/03/10 | IP: (68.56.153.38) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1080260 posted 08/10/12 10:39 PM     Remind Me!  Send Private Message   Edit Post      
well i only drove it down the block with the hose duct taped (only temporary fix tilll i can find a new one) to see if it built boost from 1st to second. i noticed though with warm engine after accel in neutral the rpm would roll from 1000 to 1500. and i notice the gauge jumped from 15psi to 20psi right when i shift. dont know if thats normal with the diverter valve tho.

Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator

Jason G.
Bourne Employment Supremacy


Galant VR-4 org Post #: 1080269 posted 08/10/12 11:21 PM     Remind Me!  Send Private Message   Edit Post      
Edit: Thought you had a 2.5 exhaust. Looks like you may have boost creep from the 3" exhaust.


Edited by Jason G. (08/10/12 11:23 PM)

Posts: 3279 | From: Anderson, SC | Member Since: 10/07/03 | IP: (99.63.228.144) | Report this post to a Moderator

Gvr41415
Junior Member
1415/2000


Galant VR-4 org Post #: 1080334 posted 08/11/12 10:48 AM     Remind Me!  Send Private Message   Edit Post   
its 2 1/2 to 3in at that elbow. i took it on the freeway for an exit just see if it was smooth all the way through and i felt power all the way through no hiccups. response is kinda slow though. how do you control or take advantage of the boost creep?



1991 #1415/2000 SOLD


Posts: 78 | From: Dallas Texas | Member Since: 11/11/11 | IP: (74.34.126.77) | Report this post to a Moderator


Pages: 1 | 2
Previous thread Next thread

Extra information
0 registered and 9 anonymous users are browsing this forum.

Galant VR4.org Moderator:  Hertz, curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 8791

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.204 seconds in which 0.171 seconds were spent on a total of 15 queries. Turbo powered.


Hertz's Galant VR-4 Page