GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » DSM front subframe
Previous thread Next thread

DSM front subframe


Lofty
Member
1049/2000


Galant VR-4 org Post #: 999599 posted 06/15/11 12:07 AM     Remind Me!  Send Private Message   Edit Post      
I searched, but I couldn't find anything. GVR4.orgs subject only search isn't working for me, and I can't sift through loads and loads of threads with the word subframe in it. Sorry

I swapped my 1g TSI AWD subframe into my GVR4. Yes, the front subframe, not just the hubs. I have a few questions.

It takes 1 full turn to get the steering to maximum wide angle. I don't think this is standard in a gvr4, unless I'm mistaken.

Also, I have to drill out the front to rear crossmember (the one that goes from the front roller mount member to the rear mount member.
It runs under the pulley side.
It's a few millimeters off on the bolt holes. I don't see this as an issue, I took it out of my totalled car, and I'm assuming it's cause I smacked something real hard. Has anyone else actually pulled this off?

Posts: 115 | From: Waukesha, WI | Member Since: 09/12/09 | IP: (24.209.143.139) | Report this post to a Moderator

123abc
Member
1945/2000


Galant VR-4 org Post #: 999648 posted 06/15/11 09:21 AM     Remind Me!  Send Private Message   Edit Post      
So you totaled your red one? I would assume the subframe and stuff should bolt right in but couldn't be sure. About the steering rack, are you sure it's centered when aligning it?

Posts: 144 | From: Winona, MN | Member Since: 03/02/07 | IP: (75.129.57.163) | Report this post to a Moderator

Lofty
Member
1049/2000


Galant VR-4 org Post #: 999756 posted 06/15/11 07:12 PM     Remind Me!  Send Private Message   Edit Post   
Yep red one was totalled.

I honed out the front crossmember holes and it bolted right up.

Steering is fine, I guess I forgot what it was like to drive a DSM, which is why it felt weird.

Just incase everyone was wondering.

You *CAN* bolt in the front subframe from a 1G AWD to a GVR4. Everything bolts right up, and is self explanitory.

However, I kept the front crossmember that holds the front motor mount, and used everything else from a 1G AWD.

Just figure I'd post this, so others can find out

Thanks guys!

Posts: 115 | From: Waukesha, WI | Member Since: 09/12/09 | IP: (24.209.143.139) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 13 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 2145

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.053 seconds in which 0.044 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page