GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » No power after 5k
Previous thread Next thread

No power after 5k


ninnyVR4
Unregistered


Galant VR-4 org Post #: 961159 posted 01/02/11 12:21 PM     Remind Me!  Send Private Message   Edit Post      
Hey guys, so fixed all the boost leaks (aside from one small one coming from the BOV flange), installed 550cc injectors, 2g maf, etc. Now when I'm in boost it pulls a lot harder, only downside is it seems to lose power at around 5k rpms. Still accelerates, but very slow and can no longer hear my o2 dump. Shift gears, o2 dump is as loud as ever, pulls hard, until 5k comes around again. What are your thoughts?

| | | IP: (76.94.113.47) | Report this post to a Moderator

Barnes
Firechicken
908/1000
237/2000


Galant VR-4 org Post #: 961160 posted 01/02/11 12:39 PM     Remind Me!  Send Private Message   Edit Post      
Do you have any other tuning equipment on the car? A Keydiver ECU? SAFC? etc etc?



-Jon Barnes
#580/2000 (Long Gone)
#908/1000 Black (Sold)
#237/2000 White

Posts: 6249 | From: Richland, WA | Member Since: 02/09/03 | IP: (71.94.174.133) | Report this post to a Moderator

ninnyVR4
Unregistered


Galant VR-4 org Post #: 961168 posted 01/02/11 01:39 PM     Remind Me!  Send Private Message   Edit Post      
Nothing at the moment. Waiting to put in a 3" DP to install my wideband to check AFR's (wondering if it's running rich causing me to lose spool)

| | | IP: (76.94.113.47) | Report this post to a Moderator

Barnes
Firechicken
908/1000
237/2000


Galant VR-4 org Post #: 961195 posted 01/02/11 04:17 PM     Remind Me!  Send Private Message   Edit Post      
I think that having no way of tuning is your problem. A 2g maf and 550's are supposed to 'cancel each other out' but it isn't perfect. I highly recommend getting that wideband installed and some way of tuning properly.



-Jon Barnes
#580/2000 (Long Gone)
#908/1000 Black (Sold)
#237/2000 White

Posts: 6249 | From: Richland, WA | Member Since: 02/09/03 | IP: (71.94.174.133) | Report this post to a Moderator

ninnyVR4
Unregistered


Galant VR-4 org Post #: 961208 posted 01/02/11 05:51 PM     Remind Me!  Send Private Message   Edit Post      
I might be able to get my hands on a SAFCII, but I don't know if it's compatible with OBDI

| | | IP: (76.94.113.47) | Report this post to a Moderator

AnotherNewb
flutterdumper


Galant VR-4 org Post #: 961264 posted 01/02/11 10:59 PM     Remind Me!  Send Private Message   Edit Post      
An SAFC2 will work on these cars the same as they work on a DSM. However, it is best to have a chip burned for your mods IE 550's and 2g mas. The ECU is in the wrong timing maps because it is seeing less airflow with the 2g mas as opposed to the factory MAS. When you start playing with an SAFC you are adjusting how much airflow your computer sees vs Actual. Thing is the computer selects its timing and fuel maps based on airflow and other factors. So if your ECU is seeing less airflow than what is really going into the engine then it is adjusting itself to the wrong perameters.

I was running a similar setup in 1947/2000. Car ran fine with stock MAS and injectors, upgraded to a 2g mas and 550 injectors, Was really missing out in the top end. Cracked the ECU open and saw lots of leaky CAP damage. Now this wasn't noticable with the stock parts, just 2g mas and 550's. Had a chip burned and the caps repaired and it was good as new.



Every terrorist killed is a victory for Wookalar

Posts: 1470 | From: Orlando, FL | Member Since: 04/26/10 | IP: (75.111.223.56) | Report this post to a Moderator

mitsuturbo
Banthony
555/1000


Galant VR-4 org Post #: 961325 posted 01/03/11 01:04 PM     Remind Me!  Send Private Message   Edit Post      
Quoting ninnyVR4:

Nothing at the moment. Waiting to put in a 3" DP to install my wideband to check AFR's (wondering if it's running rich causing me to lose spool)




Barnes is right. The two devices canceling one another out is a myth, especially in the higher RPM range. I tried it, and it yielded similar results to what you are experiencing.



92 GVR4 555/1000 11.41 @ 128.26mph
97 CBR900RR
2012 Hyundai Veloster

Posts: 3537 | From: Near Seattle, Washington | Member Since: 06/02/08 | IP: (98.237.214.181) | Report this post to a Moderator

ninnyVR4
Unregistered


Galant VR-4 org Post #: 961337 posted 01/03/11 01:40 PM     Remind Me!  Send Private Message   Edit Post      
Thanks for the help guys. By chip burned, do you mean DSMlink?

| | | IP: (76.94.113.47) | Report this post to a Moderator

Barnes
Firechicken
908/1000
237/2000


Galant VR-4 org Post #: 961341 posted 01/03/11 01:48 PM     Remind Me!  Send Private Message   Edit Post      
By burned chip we mean a KeyDiver ECU. I don't know if he is currently making any more at the moment.

A DSMLink would also help with this issue. We recommend the KeyDiver ECU because it is generally much much easier, and cheaper. On a stock block, mildly modded car, I don't think you get any better than a KeyDiver ECU.



-Jon Barnes
#580/2000 (Long Gone)
#908/1000 Black (Sold)
#237/2000 White

Posts: 6249 | From: Richland, WA | Member Since: 02/09/03 | IP: (71.94.174.133) | Report this post to a Moderator

weed831
Unregistered


Galant VR-4 org Post #: 961497 posted 01/03/11 11:48 PM     Remind Me!  Send Private Message   Edit Post      
It could be a poor ignition issue. My car was doing the exact same thing by no power after about 5k rpms. In my case it was due to putting a COP setup on it. But when I put my normal wires back on it fixed the problem. Might be completely different, but if nothing else, it may be worth looking into.

| | | IP: (70.162.20.127) | Report this post to a Moderator

ninnyVR4
Unregistered


Galant VR-4 org Post #: 961512 posted 01/04/11 01:49 AM     Remind Me!  Send Private Message   Edit Post      
I'll look into it. Not sure how old these wires are so it's possible

| | | IP: (76.94.113.47) | Report this post to a Moderator

Lukefraizer
Member


Galant VR-4 org Post #: 964239 posted 01/19/11 10:38 PM     Remind Me!  Send Private Message   Edit Post      
i was told I should this burn who can I get ahold of to get it? Im willing to beg! And payment is always a good perk! So any leads would be really helpful!



619/1000 getting there..... ish.......

Posts: 157 | From: Fort Collins CO | Member Since: 01/03/11 | IP: (76.120.120.4) | Report this post to a Moderator

AnotherNewb
flutterdumper


Galant VR-4 org Post #: 964277 posted 01/20/11 05:17 AM     Remind Me!  Send Private Message   Edit Post      
Quoting Lukefraizer:

i was told I should this burn who can I get ahold of to get it?






Every terrorist killed is a victory for Wookalar

Posts: 1470 | From: Orlando, FL | Member Since: 04/26/10 | IP: (75.111.223.56) | Report this post to a Moderator

TrendSetter
Unregistered


Galant VR-4 org Post #: 964279 posted 01/20/11 05:33 AM     Remind Me!  Send Private Message   Edit Post   
i can burn basic chips if needed. i dont really have the time to invest in major modifications since im working on my dsmap stuff but simple injector and maf changes should no be an issue.

does your boost stay steady at 5k rpm or does it fall off?

| | | IP: (70.119.231.122) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
2 registered and 12 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 7149

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.064 seconds in which 0.042 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page