GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » Re: Is this too much timing????? Anyone
Previous thread Next thread

Re: Is this too much timing????? Anyone


Blown1
Unregistered


Galant VR-4 org Post #: 917934 posted 07/26/10 07:06 AM     Remind Me!  Send Private Message   Edit Post   
As a side note I fixed(replaced)the flex section on my exhaust it was just crunched up and my wideband gauge is reading fine now. Seems like all that air in front of the sensor was what was causing the lean readings at idle lol....

Quoting keydiver:

Quoting Blown1:

So Jeff where did you move your wideband sensor to?




I didn't. I just got used to the fact I couldn't see the true AFR all the time. It still worked fine for WOT which is all I really cared about.



| | | IP: (71.235.196.54) | Report this post to a Moderator


Pages: 1 | 2
Previous thread Next thread

Extra information
0 registered and 12 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 3262

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.052 seconds in which 0.044 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page