GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » Weird sticking throttle issue
Previous thread Next thread

Weird sticking throttle issue


AWDPower
Member
739/1000


Galant VR-4 org Post #: 1069506 posted 05/31/12 09:06 PM     Remind Me!  Send Private Message   Edit Post      
My car had a strange sticking throttle issue. It only sticks when fully closed, and only when returned to closed rapidly. If I jump off the throttle, it takes quite a bit of pressure to get the pedal to budge, then it's fine. It also only happens when the engine is running, and is 100% repeatable. If I ease off, it doesn't stick. The cables and throttle body itself appear to opperate smoothly. I'm thinking it's related to the cruise control. The sticking doesn't feel like mechanical binding, it feels like vacuum is working against the pedal. Any ideas?



Jason K.
739/1000

Posts: 107 | From: Vacaville, CA | Member Since: 03/01/11 | IP: (75.33.197.19) | Report this post to a Moderator

toybreaker Galant VR4.org Moderator
it's peace of mind at 100 mph plus
1990/2000


Galant VR-4 org Post #: 1069522 posted 05/31/12 11:09 PM     Remind Me!  Send Private Message   Edit Post      
Have you had the closed throttle switch out or adjusted it recently?

Might be the edge of the throttle plate digging into the bore.

Might give the c.i.s a half a turn in and see if that helps matters.



How clean is the throttle body/plate?

A varnishy carbon can build up there and stick things up a bit.

... this usually happens when it's wet outside and/or on the first start of the day, but it can also manifest itself when you're working a trailing throttle on decel and the plate is working against a strong vacuum.


Edited by toybreaker (05/31/12 11:10 PM)

Posts: 3547 | From: Never Summer Ranch, Colorado | Member Since: 04/30/06 | IP: (208.54.38.176) | Report this post to a Moderator

AWDPower
Member
739/1000


Galant VR-4 org Post #: 1069544 posted 06/01/12 12:14 AM     Remind Me!  Send Private Message   Edit Post      
I had the throttle body off and cleaned it, but I left the idle switch alone. I adjusted the throttle cable. I worked the throttle by hand with the engine off, and couldn't duplicate it. I can duplicate the problem at idle.



Jason K.
739/1000

Posts: 107 | From: Vacaville, CA | Member Since: 03/01/11 | IP: (75.33.197.19) | Report this post to a Moderator

mooserage Galant VR4.org Administrator
New Title
254/2000


Galant VR-4 org Post #: 1069546 posted 06/01/12 12:16 AM     Remind Me!  Send Private Message   Edit Post      
Cruise control caused mine to stick when I had it, I got rid of it because it was just flat out dangerous at that point and really uncomfortable. Just a thought. Toybreaker is a genius though and you should thoroughly check everything he suggests. Seriously.



254/2000 Summit White

Posts: 1259 | From: Seattle, WA | Member Since: 05/17/04 | IP: (76.121.239.73) | Report this post to a Moderator

AWDPower
Member
739/1000


Galant VR-4 org Post #: 1069557 posted 06/01/12 01:07 AM     Remind Me!  Send Private Message   Edit Post      
I'll recheck everything. The good thing is that it is very easy to duplicate. I think I'll cause the problem so that the pedal sticks, but instead of freeing it, I'll check the throttle and see if it's stuck. If the cruise is the problem, I should be able to easily move the throttle by hand. If I can't, I'll have it narrowed down. Thanks for the help.



Jason K.
739/1000

Posts: 107 | From: Vacaville, CA | Member Since: 03/01/11 | IP: (75.33.197.19) | Report this post to a Moderator

HHIVR4
Aluminum Lung
1280/2000
138/2000



Galant VR-4 org Post #: 1069919 posted 06/03/12 02:17 PM     Remind Me!  Send Private Message   Edit Post   
Quoting mooserage:

Cruise control caused mine to stick when I had it, I got rid of it because it was just flat out dangerous at that point and really uncomfortable. Just a thought. Toybreaker is a genius though and you should thoroughly check everything he suggests. Seriously.




I had that same problem on 138.Deleted cruise and got a non cruise cable.Problem solved.

Posts: 5446 | From: Hilton Head Island SC | Member Since: 10/06/03 | IP: (67.20.144.81) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 16 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 2448

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.05 seconds in which 0.037 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page