The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Server Load Times

steve

Well-known member
Joined
Sep 11, 2003
Messages
18,895
Location
NJ
/ubbthreads/images/graemlins/applause.gif
 

DR1665

Well-known member
Joined
Oct 19, 2005
Messages
4,638
Location
Phoenix, AZ
Dreamhost FTW.

/ubbthreads/images/graemlins/applause.gif
 

4orced4door

Moderator
Joined
Jul 19, 2002
Messages
9,846
Location
Raleigh, NC
I've been getting 10-15 seconds load times for the main index lately. Once the forum is loaded pages are pretty quick though. Thoughts?
 

cheekychimp

Well-known member
Joined
Apr 19, 2004
Messages
7,333
Location
East Sussex, U.K.
Generated in 47.056 seconds in which 47.048 seconds were spent on a total of 25 queries. Turbo powered.

Generated in 56.982 seconds in which 56.976 seconds were spent on a total of 25 queries. Turbo powered.

Generated in 9.173 seconds in which 9.166 seconds were spent on a total of 25 queries. Turbo powered.

I'm getting a lot of this recently and I can load other pages at the same time that aren't cached in other tabs, so I don't think it's my connection.
 

4orced4door

Moderator
Joined
Jul 19, 2002
Messages
9,846
Location
Raleigh, NC
Generated in 25.224 seconds in which 25.217 seconds were spent on a total of 29 queries. Turbo powered.

It's like this most times I open the board (my bookmark goes to the main index).
 

DR1665

Well-known member
Joined
Oct 19, 2005
Messages
4,638
Location
Phoenix, AZ
Generated in 0.033 seconds in which 0.021 seconds were spent on a total of 14 queries. Turbo powered.

Dreamhost FTW.
 

cheekychimp

Well-known member
Joined
Apr 19, 2004
Messages
7,333
Location
East Sussex, U.K.
Generated in 60.468 seconds in which 60.419 seconds were spent on a total of 14 queries.

Ryan,

This is happening frequently at the moment. I thought it was my connection. I have been rebooting, upgrading software and firmware but the only site I am having real issues with is this one. Sites in the UK as well as the US, eBay, YouTube everything seems fine. Any thoughts?

Paul.
 

Terry Posten

Well-known member
Joined
Dec 16, 2003
Messages
9,009
Location
Davenport, Iowa USA
It is not just you.

I am seeing 20 to 30 seconds half the time.

Very depressing.
 

cheekychimp

Well-known member
Joined
Apr 19, 2004
Messages
7,333
Location
East Sussex, U.K.
Ryan,

If there is an issue with the hosting would you be willing to put up our options? I am happy making my annual donation to the board and I know a lot of others are too, but it seems that the donations are mostly required for hosting fees etc so would it be beneficial to post up what it would cost to get really good trouble free hosting with sufficient bandwidth or whatever for a year.? I'm not suggesting we make this a paying site. I know we have to be careful how we approach the issue and that you want donations to remain simply that, donations. But that said if everyone could see what costs are involved and when those payments are due together with the VR4.org account balance etc., I think people might be inclined to look at it and throw in $20 when they can see (a) exactly where the money is going and (b) experience the benefits.

I really don't want to jump the gun here if the problem is not the hosting but if it IS the hosting, I can see that people who have donated might feel that the service provider isn't coming through. I feel like we should be backing you up on this a bit mate helping you make a few calls to customer service etc if they are falling short of their promises. Or maybe we are just getting more traffic than we anticipated?

Paul.
 
Last edited:

Hertz

Staff member
Joined
Jul 29, 2002
Messages
13,501
Location
Chicago, IL
It's not really an issue with the hosting. There are a few things that are different with Dream Host vs. GoDaddy, but we had problems there too, remember? Really the problem is us, generally speaking. Me, more specifically.

I've tried to balance cost vs. performance (hey, it's a VR-4 site). Now that the coffers are replenished I've upped the plan a bit (performance) and we've got 500MB of RAM to utilize nowv (as in just now). I did recently discover that Dream Host forces compression on the pages and we were compressing the pages ourselves. Unfortunately that requires some processing power that was above our pay grade. When we go over on our plan they automatically restart (our virtual) server, this causes lags.

There's a few more tricks that GoDaddy had that DreamHost does not (by default) and I'll be testing these out when possible.

Overall the "hosting" part of things is really fast, but the database is not so much -- and that's really an issue with the design of this software. Always has been, but that's why it was kept so lean (post retention). We've slowly upped the sizes of things and we've really hit the limit of the performance without making some changes.

Change is coming and the last round of donations was spectacular. Just keep bearing with us.
 

cheekychimp

Well-known member
Joined
Apr 19, 2004
Messages
7,333
Location
East Sussex, U.K.
Thanks for posting and keeping us in the loop Ryan,

If that's the case I'll stop my whinging and wait for developments /ubbthreads/images/graemlins/rofl.gif

Paul.
 

MX4

Well-known member
Joined
Apr 9, 2001
Messages
768
Location
New Zealand
Thanks for your efforts Hertz for making this site great.
 

Hertz

Staff member
Joined
Jul 29, 2002
Messages
13,501
Location
Chicago, IL
Even though we are a virtual private server we are still using the shared database. That's the problem as we have no control over its speed. I'm installing MySQL on our server and will migrate the database to it. Bear with it for a few days and I'll try to it early Saturday.
 

cheekychimp

Well-known member
Joined
Apr 19, 2004
Messages
7,333
Location
East Sussex, U.K.
Generated in 84.258 seconds in which 84.248 seconds were spent on a total of 29 queries .... turbo lag

Quoting Hertz:
Even though we are a virtual private server we are still using the shared T66 powered database. That's the problem as it packs a hell of a punch but we have no control over when it actually hits. I'm installing antilag on our server and will migrate the database to it. Bear with it for a few days and I'll try to get spool times under a minute by Saturday.




Fixed that for ya! And no PMs about busting your balls you don't have time for dat shit! /ubbthreads/images/graemlins/rofl.gif
 

Hertz

Staff member
Joined
Jul 29, 2002
Messages
13,501
Location
Chicago, IL
Did I say Saturday morning? I meant Thursday after work. /ubbthreads/images/graemlins/smile.gif

Generated in 0.16 seconds in which 0.011 seconds were spent on a total of 13 queries
 

Terry Posten

Well-known member
Joined
Dec 16, 2003
Messages
9,009
Location
Davenport, Iowa USA
Yeah buddy, at work today was 60+ times and since I got home, it is flying.

Thank you.
 

Hertz

Staff member
Joined
Jul 29, 2002
Messages
13,501
Location
Chicago, IL
Sorry, still working out some configuration issues. I apologize for the intermittent outages.
 

Latest posts

Top