The Top Mitsubishi Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

No start/stalling issue

Parker gvr4

New member
Joined
May 20, 2024
Messages
1
Location
Havelock NC
I “recently” purchased a 88 galant vr4 in November the guy did a bunch of stuff to it (built motor, different turbo, fuel pump the list goes on) but he had it all done by a shop and knew little to nothing about the maintenance done besides what parts were on it. It has an issue where the car will run seemingly fine for a bit and then randomly cut off no sputter or anything and only at idle/low rpm. It had this issue when I purchased it and knowing nothing about the platform I thought it would be an easy fix. Mind you the only other project car I’ve ever owned is a Miata. Now after purchasing the car and driving it the car then decides it don’t wanna start anymore. It would crank and try to start but not fully start and idle. So I went through the normal checklist of
Check timing
Spark
Compression
Fuel pressure/pump
All checked good then I replaced the following in hopes it would fix it
Cas
Installed AEM fuel pressure regulator
Coolant temp sensor
Map sensor
Speed density sensor
And cleaned throttle body
To which nothing worked so I sent in my ecu to ecm link with it is chipped for and it came back good after all this I looked and found I got a dtc for code 0042 fuel pump circuit checked all the pins as directed by various forums and all seems good still getting the code but the fuel pump runs with no issues so I’m really confused by that. That being said the car does occasionally start now but it feels random and once it cuts off does not start again unless repeatedly attempting to start it and again it feels random like it’s luck that it starts again.

Please someone tell me the solution I just wanna drive my cool car.
 

gvr4ever

Well-known member
Joined
Aug 6, 2002
Messages
6,209
Location
central Indiana
Can't really diagnose remotely, but it could be a ground issue. Was the AEM FPR new? ODB1 can be a bitch to diagnose. The basics are fuel/air and spark. When things aren't working right, it can be a overwhelming thing, but in the end, the basics and fundamentals usually are the answer. Age can make things more difficult than before. While wiring degradation isn't prevalent in these cars, it's totally possible.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Top