The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

I'm lost HELP!!!!!

Ok so I have a 2000 galant and the pulley belt jumped under the timing belt which smashed the sensor, so I changed both belts, camshaft sensor crankshaft sensor also the spark plugs, checked all fuses and there fine, but now I'm stuck the car still wouldn't start!!!!
 

EfiniX

Well-known member
Joined
Oct 18, 2012
Messages
647
Location
portland, or
I don't know how much help you'll get here with a, what, 3rd or 4th generation DSM. The VR4 has an E39A motor, so we aren't even looking at the same bits as you.

That being said, check your crank position sensor.

And when you say "won't start", do you mean it's not cranking at all, or it turns over, but doesn't run? Did your timing belt break in all of this mess?
 

LIV4PSI

Well-known member
Joined
Nov 24, 2011
Messages
1,762
Location
O-H-I-O
He has an 8th gen Galant, it's not a 3rd gen DSM /ubbthreads/images/graemlins/rofl.gif

Also, E39A is the chassis code. not the engine code for our cars
 

G

Staff member
Joined
Feb 24, 2004
Messages
8,896
Location
zompton
Wrong forum.
 

Latest posts

Top