The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

fuel pump and sending unit?

MegaSuiter

Well-known member
Joined
Dec 6, 2011
Messages
122
Location
Oscoda, MI
Car stalled out the other day. Checked around it today. Couldn't hear the pump come on. Popped the trunk access cover to the pump. Messed around with the wires, still nothing. Go to take the ground off to clean it, break the stud off. Clean nice spot to metal, clip the ground on there, nothing. Looks pretty rusty. There is power running to the wires so it can't just be a relay. The Guy I bought it from said he put a 190lph pump in. Didn't s ay how recent. Pull it off and look at it here pretty quick. Where do I find a sending unit? I mean that could be the only problem if he really did d
replace the pump. And recently put a FULL tank in and the gauge read to just half way...gotta be the sending unit? Well anyways where the F do I find a unit? I have looked EVERYWHRRE. don't really want to makeshift a 1g in.
Thanks
 

gramkrakr89

Well-known member
Joined
Jan 25, 2010
Messages
308
Location
Bunker Hill, WV
mine is a modded 1g unit - works just fine and isn't as much trouble as it seems.

The walbro that came on 689 seized on me because of a destroyed filter sock... be sure it's not the pump.
 

Terry Posten

Well-known member
Joined
Dec 16, 2003
Messages
9,009
Location
Davenport, Iowa USA
If you want brand new, you will have to go aftermarket but they are hard to find and are pricey.

Post up a "want to buy" ad in the correct forum and you may get lucky to find a really clean used stock unit or a used aftermarket unit.

Good luck.
 

MegaSuiter

Well-known member
Joined
Dec 6, 2011
Messages
122
Location
Oscoda, MI
I am sure about 80% sure it isn't the pump. I will take it off today. Does a warlboro 190lph have like any indicators on it? Specs? Ways of telling that it is what he says it is? Thanks guys!
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Recent Classifieds Listings

Top