The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

fuel injector # 1 issue

dsmfever

Member
Joined
Dec 26, 2013
Messages
15
Location
boise, id
both wires to on the clips have power to them except # 1. i tried a known working resister pack and same issue. ive also have tried 3 known well working ecus( no leaks or bad boards) and same issue. i have power tested anything that i can think of. i tested the power wire to the all injectors directly at the ecu. all injectors have constant power except #1. so directly from the ecu the power is sh*t to #1. what would be the deal?

oh and this problem seems to be intermittent as well.

stock 450cc, stock ecus
 

strokin4dr

Well-known member
Joined
Aug 30, 2005
Messages
2,768
Location
Savannah, GA
Check all wiring from the resistor box to the injectors. Sounds like a break or bad wire. I had bad sensor ground wire on the vr4 I picked up almost 2 yrs ago and after exposing the wire completely everything still looked fine with it. Turned out to be broken internally. Pain in the arse to find issues like that sometimes. Good luck.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned
Top