The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Ecu dead?

mcbride89

Well-known member
Joined
Dec 17, 2012
Messages
133
Location
Belmar,NJ
Got the car back together after changing up some things. I had pulled the ecu to inspect during this as well, had a burnt IC105 driver which explained my irraddic idle. Now with the ecu plugged in. I get no check engine light leadin me to believe that the ecu isn't getting power.

I checked the MPI relay on pins 10&8 and 9&7 and that checked out good. MPI fuse is good. On the pin 103 for constant backup power I have 12volt. But no where else. I just get a click from the relay when I go to turn her on. Am I missing something? I've been getting friendly with my multimeter so please tell me other things to check. Could my ecu have just sh*t the bed from being pulled for so long?

Ant
 

IncorpoRatedX

Well-known member
Joined
May 28, 2003
Messages
5,593
Location
Arizona
sounds like a dead ecu to me. Connect a logger to it and see if it does anything. If you dont get any CEL the bulb is either burned out or the ECU is dead. You'll have power to the ECU pins as you should, and the MPI relay will respond to key positions, but the ECU wont do anything if it's toast.
 

mcbride89

Well-known member
Joined
Dec 17, 2012
Messages
133
Location
Belmar,NJ
Well I thought I had the clutch switch grounded but I unplugged it just to check. And wallah I got it to start.. I went to check and had power at 102 and a heartbeat at 1... I don't get it. I may have a loose wire. Regardless that ecu needs to go. I did have it running a few times today for maybe no more then a minute to check for leaks.

So far no leaks on the return line or new pass. Axle seal.. Crossing my fingers tomorrow

Thanks guys
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned
Top