The Authoritative Galant VR-4 Resource

Join the best E39A 1991-1992 Mitsubishi Galant VR-4 community and document your GVR4 journey.

  • Software Upgraded - Reset Your Password to Login
    In order to log in after the forum software change, you need to reset your password. If you don't have access to the email address you used to register your GVR4.org account, you won't be able to reset your password. In that case, follow the instructions here to regain access to the forum.

Cold starting issue

newpoppop

Well-known member
Joined
Oct 12, 2009
Messages
59
Location
Gibbstown, NJ
I have searched on here and have not found this issue, here goes. cold start, have to initiate cranking 3 times before engine fires up, all the time when cold. when warm, it fires right up, if hot, may take a couple tries, on the first couple hot tries, it may run, but sputter, and die when I hit the gas. 91 Galant VR-4, Stock with FMIC.
thanks for any and all suggestions...

Chris /ubbthreads/images/graemlins/banghead.gif /ubbthreads/images/graemlins/banghead.gif
 

MellowVR4

Well-known member
Joined
Jul 25, 2009
Messages
1,662
Location
Milwaukee, Wi
Maybe your FPR, Or the coolant temp sensor. /ubbthreads/images/graemlins/dunno.gif
 

vr4play

Well-known member
Joined
Feb 7, 2008
Messages
397
Location
Cincinnati, Ohio
Sounds like coolant temp sensor. Do you have a way to log. If so see what the coolant temp sensor is reading. Normally when they go bad they read something like -75 and the ecu just tries to pour fuel in and it gets pissed off rich.
 
Support Vendors who Support the GVR-4 Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications RixRacing RockAuto RTM Racing STM Tuned

Recent Forum Posts

Top