GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » General VR4 Discussions » Hyper Flashing on both indicators
Previous thread Next thread

Hyper Flashing on both indicators


TheBen12345
Newbie


Galant VR-4 org Post #: 1243207 posted 07/04/18 03:56 AM     Remind Me!  Send Private Message   Edit Post      
Hello,
new to the forum. Just wondering how to fix hyper flashing on my indicators.
All the bulbs are working. The fuse under the dash (inside) is fine. There are NO LED bulbs fitted.
The hazards work fine. Could the tail lights have LEDs in them?
Also is there a simple relay i need to switch out or install?
Thanks



1991 galant vr4

Posts: 8 | From: Perth | Member Since: 07/02/18 | IP: (203.219.249.216) | Report this post to a Moderator

467
mass moment of inertia
467/1000


Galant VR-4 org Post #: 1243210 posted 07/04/18 08:14 AM     Remind Me!  Send Private Message   Edit Post      
Could be led bulbs, or incandescent bulbs that are a lower wattage than OEM, burnt out bulbs, or a relay that is bad / not the correct part number (internal resistor value contols the frequency of the relay). As I recall the relay is behind the bottom knee dash cover to the left of the steering wheel on a LH drive model.


Edited by 467 (07/04/18 08:20 AM)

Posts: 884 | From: Fremont Ca | Member Since: 03/16/01 | IP: (24.6.21.118) | Report this post to a Moderator

TheBen12345
Newbie


Galant VR-4 org Post #: 1243211 posted 07/04/18 09:41 AM     Remind Me!  Send Private Message   Edit Post      
I have a RHD galant. Will look for the relay tomorrow. What’s the OEM wattage for the bulbs?

Posts: 8 | From: Perth | Member Since: 07/02/18 | IP: (203.219.249.216) | Report this post to a Moderator

467
mass moment of inertia
467/1000


Galant VR-4 org Post #: 1243213 posted 07/04/18 12:23 PM     Remind Me!  Send Private Message   Edit Post      
Ah, that reminds me of another possibility. There are single bulb front corner indicator lenses (with dual filaments), and dual bulb single filament indicator lenses that are available on these cars. The dual bulbs use less wattage than the single bulb by design, if I recall properly.

Someone may have switched out the indicator lenses on your car because they liked the double design over the single design. In that case, I believe there are flasher units that are specifically designed to be used with LED bulbs that have a fixed flash rate regardless of the wattage of the bulbs. I am not sure if it would detect a bulb failure though. I expect that type of flasher relay might solve your problem.

Digging a little deeper, MB302373 is the apparent Mit relay part number for the USA models, and the Wattage is printed on the side.click The LED compatable relay equivalent appears be here.click

This is all based on my recollection from years ago, and the USA spec parts, so you will have to double check this for yourself. Good luck, hope it helps.


Edited by 467 (07/04/18 03:49 PM)

Posts: 884 | From: Fremont Ca | Member Since: 03/16/01 | IP: (24.6.21.118) | Report this post to a Moderator

fuel
"Just to be pedantic!"


Galant VR-4 org Post #: 1243242 posted 07/06/18 11:46 AM     Remind Me!  Send Private Message   Edit Post      
To add another spanner in the works, if his car is an AUDM model, it will have the turn signals in the front bumper just like a USDM, with the addition of some repeater lamps on the front fenders like the European models. JDM models do not have the repeaters.



'91 E39A Galant VR-4 Evolution | '80 A164A Eterna GSR Turbo

-- Visit my JDM Galant VR-4 info & specifications site here! --

Posts: 2093 | From: Toronto, ON, Canada | Member Since: 02/23/09 | IP: (209.226.66.172) | Report this post to a Moderator

TheBen12345
Newbie


Galant VR-4 org Post #: 1243258 posted 07/07/18 12:18 AM     Remind Me!  Send Private Message   Edit Post   
I managed to figure out that the indicators must have been switched out or something by previous owner. The indicator had the double bulb system (like you said) and so was using a lower wattage bulb. Plus my owners manual says that the indicator is suppose to be on the bumper, which my bumper does not have. In the end a simple LED relay flasher would fine.
Cheers for the help guys!



1991 galant vr4

Posts: 8 | From: Perth | Member Since: 07/02/18 | IP: (202.161.125.198) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 36 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 554

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.224 seconds in which 0.205 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page