GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » Limp home condition cause after engine wash ( or large puddle)
Previous thread Next thread

Limp home condition cause after engine wash ( or large puddle)


Terry Posten
Old Balls
425/1000


Galant VR-4 org Post #: 1001481 posted 06/24/11 11:53 PM     Remind Me!  Send Private Message   Edit Post      
I washed the engine bay late today and cause a limp home condition after driving it for a few miles. This has happened once before years ago when I was running a 3G MAS and now I am running speed density.

After limping it home the last 4 miles and racking my brain to figure out what still could be the common thing that is causing this issue I came to a few ideas.

The very first time this happened it was a torrential rain and after a huge puddle it started acting up. I concluded that it was the MAS that got wet so I dried it out over a few hours and it was fine. So I figured that was it. This time I don't have any MAS and was very perplexed as to what it could be since all the new wiring harnesses for the speed density setup was done with GM seal-tight connectors.

I found that the large stock engine harness plug that sits on the passenger side frame rail was the only common thing between the old stock setup and the new SD setup and sure enough it was soaked. Inside and out. I blew it out with 120psi air and it runs great again.

So, if your car will only idle and rev to 1500 rpms and fall on it's face, pull that plug apart and dry it the best you can.

Posts: 9009 | From: Davenport, Iowa USA | Member Since: 12/16/03 | IP: (173.27.92.172) | Report this post to a Moderator

HHIVR4
Aluminum Lung
1280/2000
138/2000



Galant VR-4 org Post #: 1001600 posted 06/25/11 04:37 PM     Remind Me!  Send Private Message   Edit Post      
Post a pic so we know which one your talking about.

Posts: 5446 | From: Hilton Head Island SC | Member Since: 10/06/03 | IP: (174.252.152.192) | Report this post to a Moderator

Terry Posten
Old Balls
425/1000


Galant VR-4 org Post #: 1001617 posted 06/25/11 05:34 PM     Remind Me!  Send Private Message   Edit Post      




1992 Galant VR4 click
2010 Outlander GT S-AWC Premium w/nav (wife daily)
2010 Jaguar XF Premium Luxury (my daily

Posts: 9009 | From: Davenport, Iowa USA | Member Since: 12/16/03 | IP: (173.27.92.172) | Report this post to a Moderator

Nartanian
Wears Turbo Chrysler Emblems with Pride, Watches Soap Operas all day.
633/1000


Galant VR-4 org Post #: 1001752 posted 06/26/11 02:18 PM     Remind Me!  Send Private Message   Edit Post      
Thanks for the info and pic. I plan on washing my engine bay next week. This helps.



^^ The post above is guaranteed awesomeness in every way possible because the poster is pure Tard ^^


Edited by Nartanian (06/26/11 02:18 PM)

Posts: 611 | From: Richfield, MN | Member Since: 01/14/09 | IP: (75.72.29.126) | Report this post to a Moderator

Jesh
Member +
898/1000


Galant VR-4 org Post #: 1001852 posted 06/26/11 10:06 PM     Remind Me!  Send Private Message   Edit Post      
Well that explains the problem I had a few years ago...



'92 Galant VR4 898/1000
'91 Galant GSX - parts
'93 Laser RS - gone

Posts: 281 | From: Soldotna, Alaska | Member Since: 11/12/09 | IP: (216.67.52.55) | Report this post to a Moderator

HHIVR4
Aluminum Lung
1280/2000
138/2000



Galant VR-4 org Post #: 1002008 posted 06/27/11 04:51 PM     Remind Me!  Send Private Message   Edit Post      
Wow..Your car is super clean..

Posts: 5446 | From: Hilton Head Island SC | Member Since: 10/06/03 | IP: (174.252.177.94) | Report this post to a Moderator

SleepinGVR4
What are we going to do today Ferb?
629/2000


Galant VR-4 org Post #: 1002015 posted 06/27/11 05:32 PM     Remind Me!  Send Private Message   Edit Post      
Thanks Terry this also explains a problem I had not to long ago.



Sean

Posts: 2483 | From: Danville, Pennsylvania | Member Since: 02/12/03 | IP: (70.44.250.133) | Report this post to a Moderator

BoostedAWD91
Senior Member
815/2000


Galant VR-4 org Post #: 1003034 posted 07/03/11 11:06 AM     Remind Me!  Send Private Message   Edit Post      
I had the happen years ago at 5am going to work which really pissed me off and I was smelling oil vapors.I looked around and around not finding anything, then just happened to think maybe my catch can is full so I opened the drain and dumped some out and it ran fine again. Not sure if a full catch Can will bring those conditions but it seemed to do the trick.



#815/2000- Lexus Pearl White


Posts: 2937 | From: Danville,Pa | Member Since: 03/01/07 | IP: (71.181.135.40) | Report this post to a Moderator

Barnes
Firechicken
908/1000
237/2000


Galant VR-4 org Post #: 1003052 posted 07/03/11 01:52 PM     Remind Me!  Send Private Message   Edit Post   
Next time this happens you should put your car into a gigantic bag of rice.



-Jon Barnes
#580/2000 (Long Gone)
#908/1000 Black (Sold)
#237/2000 White

Posts: 6249 | From: Richland, WA | Member Since: 02/09/03 | IP: (75.142.64.139) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
2 registered and 47 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 5178

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.206 seconds in which 0.19 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page