GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Newbies » Fuel Pump Nightmare (pics)
Previous thread Next thread

Fuel Pump Nightmare (pics)


Rjukan
Unregistered


Galant VR-4 org Post #: 474589 posted 05/05/07 10:23 AM     Remind Me!  Send Private Message   Edit Post      
No wonder my car stinks of gas a lot of the time. How incredibly dangerous is this situation? Last time I filled it up there was gas everywhere, pouring out from under the car near the gas cap, and even in the trunk. After removing the cover this is the sight I was greeted with:


The PO said the pump was upgraded to a walbro 255... So it looks like they removed the 12V supply wire from the pump assembly top plate and left the hole open, then they have it coming up between the plate and the tank I dont get it.


Its so rusty in there, it doesnt look like the pump has been out in years and years. Im going to follow the Vfaq for upgrading the fuel pump to remove it some time this week and see whats going on. I wonder how much of this Im going to have to replace?

| | | IP: (74.73.208.71) | Report this post to a Moderator

TonyNZ
Unregistered


Galant VR-4 org Post #: 474658 posted 05/05/07 02:08 PM     Remind Me!  Send Private Message   Edit Post      
Yum! That looks BAD! That wire could have shorted out at any time, possibly starting a fire with all that gas that would be around because of the seal not being comolete. Glad you found it before coming to any harm!

| | | IP: (125.237.59.237) | Report this post to a Moderator

chris
Unregistered


Galant VR-4 org Post #: 474675 posted 05/05/07 02:53 PM     Remind Me!  Send Private Message   Edit Post      
dayum! Good thing you found that or we would have lost another vr4 to fire damage! Looks like your going to need new tank and part that holds the pump and sending unit.. I think it was JNZ that had a sweet setup that used a bosch pump. Rust sucks believe me living in the northeast has its disadvantages when coming to cars and rusting.

| | | IP: (72.209.37.84) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 474696 posted 05/05/07 04:45 PM     Remind Me!  Send Private Message   Edit Post      
Thanks for the replies, I dont think I need a new tank (I hope) because it seems like its surface rust. But the whole pump/sending assembly looks like it has to go.

I never worked on a fuel system before and Im not looking forward to learning on this one. My first problem is that I have a good half tank of gas still left in there. I dont really want to drive the car anymore considering how bad the problem is, and I dont have a container large enough to catch that much gas if I use the drain plug. I have read of using the DSMlink to activate the pump and remove the fuel line going to the rail and have it pump into a container there, this way I can turn it off and use (2) 5gal containers.

Ive got a lot of searching to do tonight lol. Thanks again for any suggestions.

| | | IP: (74.73.208.71) | Report this post to a Moderator

Rausch Galant VR4.org Moderator
Rock Star Status


Galant VR-4 org Post #: 474718 posted 05/05/07 06:16 PM     Remind Me!  Send Private Message   Edit Post      
i bet you could get those nuts off. just hit it with the PB blaster for a few days, and go at it with some care. there are guys on here who had it way worse, and managed to save the sending units, so have faith. i personally had it so bad, you couldn't tell there were nuts on the studs. it was just little balls of rust. i ended up getting a new stailess unit from Alex (awesome by the way) and although it was a bit of a tough fit, that and some stainless rivets, and i was good to go. Too bad they don't make them anymore....at least i think they don't. good kuck man!



Rance lives here...
Founder of Sold out to BMW Cru, then sold out there too.


Posts: 12049 | From: Cleveland, OH | Member Since: 12/21/04 | IP: (68.109.207.53) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 474720 posted 05/05/07 06:31 PM     Remind Me!  Send Private Message   Edit Post      
I disconnected the battery and removed all of that black tape that was on the 12V wire, take a look at this pretty picture:


Damn I have been really really lucky.

| | | IP: (74.73.208.71) | Report this post to a Moderator

IslandVr4
Unregistered


Galant VR-4 org Post #: 474722 posted 05/05/07 06:36 PM     Remind Me!  Send Private Message   Edit Post      
dude that is scary, glad you caught it before something bad came of it.

| | | IP: (69.29.197.223) | Report this post to a Moderator

Rausch Galant VR4.org Moderator
Rock Star Status


Galant VR-4 org Post #: 474728 posted 05/05/07 06:55 PM     Remind Me!  Send Private Message   Edit Post      
yeah that really sucks...after i installed the stainless unit, the gromet that held the little nut and bolt for the power wire fell out, and had worn the wire down. so imagine a hot wire straight into the fuel pump. we were on the way to Summit racing, and it popped the MPI fuse, i replaced the fuse, and it popped again in like 5 minutes. when we finally stopped to investigate (we were in the parking lot at this point) the wire had seperated from the nut/grommet thing, and was floating around in the tank. now with the sending unit rivited in, i had to buy a precision pick set from summit, and fish the wire out of the tank through the grommet hole...that was fun. i then fitted connectors to the wire ends to get the car home. i got lucky, and didn't cause any fires or anything, and it looks like you avoided the same problem....nice catch.



Rance lives here...
Founder of Sold out to BMW Cru, then sold out there too.


Posts: 12049 | From: Cleveland, OH | Member Since: 12/21/04 | IP: (68.109.207.53) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 474733 posted 05/05/07 07:15 PM     Remind Me!  Send Private Message   Edit Post      
Wow man, that sounds insane. I cant imagine fishing anything out of that little grommet hole. How the hell did you see anything lol? Yeah thats a really nice save, Im glad you avoided disaster too.

Well, I guess my only option at this point is to find some containers large enough to hold all of the gas I have left in the tank. Man thats going to suck, I hate gasoline lol Im so paranoid.

| | | IP: (74.73.208.71) | Report this post to a Moderator

Rausch Galant VR4.org Moderator
Rock Star Status


Galant VR-4 org Post #: 474735 posted 05/05/07 07:19 PM     Remind Me!  Send Private Message   Edit Post      
lets just say i got really good with tiny pick sets. i had to do it by feel, as i couldn't see shit! ...i think you could get those things loose/off without heat or grinding. remember the fumes are what ignite, not the fluid itself. if you just keep PB blasting the nuts, you could probably get the off. at that point, you could pull the sending unit, and fix all that crap the PO did. is that what you're planning?



Rance lives here...
Founder of Sold out to BMW Cru, then sold out there too.


Posts: 12049 | From: Cleveland, OH | Member Since: 12/21/04 | IP: (68.109.207.53) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 474739 posted 05/05/07 07:40 PM     Remind Me!  Send Private Message   Edit Post      
Yeah thats pretty much exactly what I was planning as soon as I figure out what to do with all of that gas. I have to look around tomorrow for gas cans, and something to drain the tank into. Does pepboys or autozone sell something big enough to hold that much gas? Im guessing there is at least 7-8 gallons left in the tank

| | | IP: (74.73.208.71) | Report this post to a Moderator

jepherz Galant VR4.org Moderator
Too Clean
1881/2000
50/1000


Galant VR-4 org Post #: 474746 posted 05/05/07 08:29 PM     Remind Me!  Send Private Message   Edit Post      
No wonder why DSMs have such a reputation; people skimp on everything they do! Best of luck on the fix!



-Jeff
1881/2000
50/1000

Posts: 7870 | From: KC, Missouri | Member Since: 08/08/04 | IP: (75.87.84.184) | Report this post to a Moderator

Rausch Galant VR4.org Moderator
Rock Star Status


Galant VR-4 org Post #: 474749 posted 05/05/07 08:35 PM     Remind Me!  Send Private Message   Edit Post      
i wouldn't bother with draining the gas, if you're not gonna use any heat or grinder. if you're really worried, just tape over the grommet hole, or stuff a rag in it or something....you should be good to go. i drilled my studs out when i did mine with fuel in the tank, i just wrapped everything around the sending unit with damp rags, and kept spraying the area down with pb or WD-40. i drilled right through with not an issue. I was worried about the drain plug breaking in the tank, and really didn't want to try to siphon a 1/2 tank of gas with nothing to put it in. you should be fine without draining the tank.



Rance lives here...
Founder of Sold out to BMW Cru, then sold out there too.


Posts: 12049 | From: Cleveland, OH | Member Since: 12/21/04 | IP: (68.109.207.53) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 474762 posted 05/05/07 09:06 PM     Remind Me!  Send Private Message   Edit Post      
Ok cool, but what about when I get the whole assembly out? I can stuff rags into that large opening and not worry about rust and other crap falling into the tank?

When you drilled out the studs on yours, what happened to all of the metal shavings that must have fallen into the tank? The screen on the pump is good enough to block any of that from entering the engine?

Also if I was to goto a junkyard and look for another sending unit, would I be able to use one from an awd t/e/l? I think I remember reading something about them being too long to fit in the galant tank. Thanks again for the input.

| | | IP: (74.73.208.71) | Report this post to a Moderator

Rausch Galant VR4.org Moderator
Rock Star Status


Galant VR-4 org Post #: 474763 posted 05/05/07 09:13 PM     Remind Me!  Send Private Message   Edit Post      
i just blasted the area off with compressed air really good before i pulled the sending unit. i used a magnet in the tank to grab most of the shavings, but was out of options at the time, so i'm sure there's still some in there. if you're not drilling, don't sweat it. just cover the hole with a rag or something, and set a book or something on it too keep it covered well.

the T/E/L sending units are indeed too long. i think a few guys cut them down, and modded them to work though. it would be best if you can save yours though.



Rance lives here...
Founder of Sold out to BMW Cru, then sold out there too.


Posts: 12049 | From: Cleveland, OH | Member Since: 12/21/04 | IP: (68.109.207.53) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 474767 posted 05/05/07 09:34 PM     Remind Me!  Send Private Message   Edit Post      
OK sounds like a plan. Man this is going to be really interesting lol. Ill post a bunch of pictures of my progress as its happening.

Im trying to guess why the PO wired it this way to maybe get an idea of whats awaiting me when I get the pump out. At least he included the rewire kit for it so I have that to work with.

| | | IP: (74.73.208.71) | Report this post to a Moderator

Rausch Galant VR4.org Moderator
Rock Star Status


Galant VR-4 org Post #: 474768 posted 05/05/07 09:35 PM     Remind Me!  Send Private Message   Edit Post      
good luck, and start PB blasing everything....keep us posted, and if you get stuck, drop a message, or shoot me a PM. have fun!!!



Rance lives here...
Founder of Sold out to BMW Cru, then sold out there too.


Posts: 12049 | From: Cleveland, OH | Member Since: 12/21/04 | IP: (68.109.207.53) | Report this post to a Moderator

G
obsessed with the turds of others
486/1000


Galant VR-4 org Post #: 474827 posted 05/06/07 03:12 AM     Remind Me!  Send Private Message   Edit Post      
Daaam.



www.japanesenostalgiccar.com
www.nostalgic.co.jp

Posts: 8822 | From: zompton | Member Since: 02/24/04 | IP: (24.145.203.179) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 474882 posted 05/06/07 10:16 AM     Remind Me!  Send Private Message   Edit Post      
Lol, here is a photo update!

Man, in addition to that shitty splice above with the eyelet and post, this is what I found under the rest of the black tape. I cant imagine the losses the current had going through this line:


PB is amazing stuff... I went out and picked up a can of it and 14mm and 3/4 flare wrenches. It was a bitch, but not at all as bad as I was expecting:


Success!! (*edit: my wife said I was stupid for having that picture here lol)


I have taken that post off the 12V line and routed it back through the hole in the top of the plate. I plan on splicing the wire nicely to the source:


Any suggestions?


Edited by Rjukan (05/09/07 09:19 PM)

| | | IP: (74.73.208.71) | Report this post to a Moderator

Rausch Galant VR4.org Moderator
Rock Star Status


Galant VR-4 org Post #: 474887 posted 05/06/07 10:39 AM     Remind Me!  Send Private Message   Edit Post      
i wound up using a bunch of heatshrink tubing over the wire where it passes through the sending unit. i just kept adding a piece, and shrinking it, unti it was coser to the diameter of the hole. i mixed up a little epoxy, and filled in the gap with that. that way its solid, and sealed, and the edge can't cut through the wire...glad you got it apart in one piece. nice work man!



Rance lives here...
Founder of Sold out to BMW Cru, then sold out there too.



Edited by VRausch4 (05/06/07 10:45 AM)

Posts: 12049 | From: Cleveland, OH | Member Since: 12/21/04 | IP: (68.109.207.53) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 474932 posted 05/06/07 12:11 PM     Remind Me!  Send Private Message   Edit Post      
Hey thanks a lot!

I am done, everything is back in and I have to connect the battery and give it a shot. Is there anything else I have to do or it will prime itself after trying to start it a few times?

I am really happy with how it came out, thanks a ton for the help VRausch4.

| | | IP: (74.73.208.71) | Report this post to a Moderator

IslandVr4
Unregistered


Galant VR-4 org Post #: 474933 posted 05/06/07 12:17 PM     Remind Me!  Send Private Message   Edit Post      
should prime on it own with just a second or two delay.

| | | IP: (24.113.88.95) | Report this post to a Moderator

Rausch Galant VR4.org Moderator
Rock Star Status


Galant VR-4 org Post #: 474935 posted 05/06/07 12:21 PM     Remind Me!  Send Private Message   Edit Post      
Quote:

I am really happy with how it came out, thanks a ton for the help VRausch4.


no problem. if you have a logger, you can turn the pump on by itself. if not, just crank it over a few times like stated above, and it should be good to go.



Rance lives here...
Founder of Sold out to BMW Cru, then sold out there too.


Posts: 12049 | From: Cleveland, OH | Member Since: 12/21/04 | IP: (68.109.207.53) | Report this post to a Moderator

ggsxkid
teh UBer FAIL
1692/2000


Galant VR-4 org Post #: 474957 posted 05/06/07 01:45 PM     Remind Me!  Send Private Message   Edit Post      
my sending unit in the gsx is worse than his... i hope the pump doesn't take a shit any time soon!!



90 Galant GS-X Nordic Blue, daily driver .
91 Galant VR-4 Belize Green #1692/2000, now with curtis.
06 Mazda5 White, family truckster.
Mitsubishi, a company so good it doesn't need secondary "luxury car" divisions

Posts: 849 | From: Nashville,Tn/Lake Zurich Il | Member Since: 12/15/05 | IP: (216.244.50.199) | Report this post to a Moderator

Rjukan
Unregistered


Galant VR-4 org Post #: 475035 posted 05/06/07 05:21 PM     Remind Me!  Send Private Message   Edit Post   
Lol, the point I was making wasnt really the condition of the sending unit or pump. It was the incredibly horrible hack wiring job that was done. That was the cause of the gas smell in the car and the spilling problem when the tank was full.

I am about to go and start the car now, lol Im nervous.

| | | IP: (74.73.208.71) | Report this post to a Moderator


Pages: 1 | 2 | 3
Previous thread Next thread

Extra information
0 registered and 30 anonymous users are browsing this forum.

Galant VR4.org Moderator:  Hertz, curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 8222

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.27 seconds in which 0.208 seconds were spent on a total of 15 queries. Turbo powered.


Hertz's Galant VR-4 Page