†††GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Newbies » NO START-
Previous thread Next thread

NO START-


yeti
Nope still sticky fingers


Galant VR-4 org Post #: 1240851 posted 12/07/17 04:06 PM     Remind Me!  Send Private Message   Edit Post      
So I havenít started her up in a year but Iím puttin her back on the road as my daily driver again because I need a new vice for all my time...

I hooked everything back up and tried to fire her up but only cranking away.

So My guess was that the 3 year old gas is probably bad, but before I drain the gas and replace it, Thought Iíd check my ecu out and see how the driver/capacitors were sittin, can definitely see some fry marks but need a second opinion and a recommendation where to send my ecu if it is infact in bad shape.





~turbohair~


Edited by yeti (12/07/17 11:41 PM)

Posts: 716 | From: san diego california | Member Since: 10/13/10 | IP: (2607:fb90:6643:f) | Report this post to a Moderator

badams
Bungie Battery
50/1000


Galant VR-4 org Post #: 1240852 posted 12/07/17 06:11 PM     Remind Me!  Send Private Message   Edit Post      
Get it checked out by ECMTuning. They will go through it and tell you what is needed.

click



-Blake

Posts: 121 | From: KC, MO | Member Since: 06/16/14 | IP: (2600:1700:8b30:5) | Report this post to a Moderator

yeti
Nope still sticky fingers


Galant VR-4 org Post #: 1240856 posted 12/07/17 06:46 PM     Remind Me!  Send Private Message   Edit Post      
Thanks ya just sent them a mesage with pics to see if that is indeed the problem before I send it out.

Contacting a local buddy with a 1g ecu so I can try it out to make sure mine is bad first



~turbohair~

Posts: 716 | From: san diego california | Member Since: 10/13/10 | IP: (2607:fb90:665d:d) | Report this post to a Moderator

yeti
Nope still sticky fingers


Galant VR-4 org Post #: 1240858 posted 12/07/17 07:38 PM     Remind Me!  Send Private Message   Edit Post      
Also so I got a spare ECU how do I make sure not to fry my buddyís computer.

Should I remove the isc plug or do my drivers not look fried ?

Just wanna make sure not to hurt this computer



~turbohair~


Edited by yeti (12/07/17 07:45 PM)

Posts: 716 | From: san diego california | Member Since: 10/13/10 | IP: (2607:fb90:665d:d) | Report this post to a Moderator

yeti
Nope still sticky fingers


Galant VR-4 org Post #: 1240859 posted 12/07/17 09:04 PM     Remind Me!  Send Private Message   Edit Post      
Well shit I swapped in a new ECU that works and plugged my Ecm chip in and nothing changed.

Iím guessing my injectors are not working so Iíll be swapping in some stocks I guess and a stoc eprom chip.

Problem is I have a 2g maf set up. Do I need to just get a laptop and start ecmlink and revert back to stock tune on 450cc and 2g maf ?


Havenít worked on cars in a while sorry for all the questions



~turbohair~


Edited by yeti (12/08/17 03:24 AM)

Posts: 716 | From: san diego california | Member Since: 10/13/10 | IP: (2607:fb90:6644:c) | Report this post to a Moderator

raptorWagon
less than one year to my birthday
1350/2000
362/1000


Galant VR-4 org Post #: 1240860 posted 12/07/17 09:22 PM     Remind Me!  Send Private Message   Edit Post      
Probably isn't the injectors, is the MPI Relay and Fuel pump working?



92 Galant VR-4 362/1000
76 Galant Coupe
79 Galant Sigma Wagon
88 Fiji Blue Starion
94 Montero SR

Posts: 2693 | From: Oak Harbor, WA | Member Since: 05/17/07 | IP: (2601:601:4500:52) | Report this post to a Moderator

yeti
Nope still sticky fingers


Galant VR-4 org Post #: 1240863 posted 12/07/17 11:39 PM     Remind Me!  Send Private Message   Edit Post      
I can hear the walhbro priming and Iíve got pressure to the afpr hitting 45psi

How can I check the mpi relay?
Iíll google it as I post this.

Any chance my tune got deleted after years of sitting?



~turbohair~

Posts: 716 | From: san diego california | Member Since: 10/13/10 | IP: (68.8.199.93) | Report this post to a Moderator

Nebraska
Member
1099/2000


Galant VR-4 org Post #: 1240864 posted 12/07/17 11:50 PM     Remind Me!  Send Private Message   Edit Post      
Didnít you say 3 year old gas?



1099/2000 Summit white
"Do it once, Do it right."

Posts: 120 | From: Lincoln, NE | Member Since: 04/09/15 | IP: (66.87.143.177) | Report this post to a Moderator

yeti
Nope still sticky fingers


Galant VR-4 org Post #: 1240866 posted 12/08/17 03:22 AM     Remind Me!  Send Private Message   Edit Post      
Already drained and refueled, do you think I need to drop the gas tank and clean it?



~turbohair~


Edited by yeti (12/08/17 03:28 AM)

Posts: 716 | From: san diego california | Member Since: 10/13/10 | IP: (2607:fb90:6644:c) | Report this post to a Moderator

strokin4dr
fighting them with a large needle
1280/2000
1135/2000


Galant VR-4 org Post #: 1240867 posted 12/08/17 03:47 AM     Remind Me!  Send Private Message   Edit Post      
I would say it is most likely the injectors stuck/clogged from sitting. I would absolutely remove the fuel sending unit and take a look inside the tank before trying any other injectors. At the very least replace the pickup sock while in there and then replace the fuel filter before the rail. No sense in guessing on a dirty fuel system and chance screwing up more injectors, or running lean due to lack of fuel flow.



1908- sold and missed.
1280- 2.3, FP 35R, E85, etc.
1135- 100% stock - 88k miles
'93 Mirage hatch- 4g63, AWD, etc (hoarding for build)

Posts: 2742 | From: Savannah, GA | Member Since: 08/30/05 | IP: (2601:900:8201:b5) | Report this post to a Moderator

iceman69510
Turn Right Racing
855/2000
828/1000


Galant VR-4 org Post #: 1240868 posted 12/08/17 06:42 AM     Remind Me!  Send Private Message   Edit Post      
Three things necessary for combustion- spark, fuel, compression. Which of these have you verified you have?

May need to put some oil in the cylinders to get some compression once you have verified you have spark and fuel.



91 VR4 855 Nile Black
92 VR4 828 Belize Green-Daily driver status
91 VR4 115 Nile Black -SOLD

Posts: 10490 | From: Michigan | Member Since: 03/05/01 | IP: (205.144.100.200) | Report this post to a Moderator

yeti
Nope still sticky fingers


Galant VR-4 org Post #: 1240871 posted 12/08/17 03:13 PM     Remind Me!  Send Private Message   Edit Post      
Ok so this morning I went thru the fuel system, popped a new fuel filter in and presto she fired right up.

Now sheís running on 2 cylinders , cylinder 4&3 are running and 1&2 have spark so Iím guessing those two injectors are at fault?

Guess Iíll be switching the injectors around to see if that changes anything.

So far so good, thank you everyone!!



~turbohair~


Edited by yeti (12/10/17 02:56 AM)

Posts: 716 | From: san diego california | Member Since: 10/13/10 | IP: (2607:fb90:4c52:e) | Report this post to a Moderator

yeti
Nope still sticky fingers


Galant VR-4 org Post #: 1240913 posted 12/11/17 12:00 PM     Remind Me!  Send Private Message   Edit Post   
So I swapped the injectors around and got cylinder 1&2 to start running but now 3&4 are not because of my stuck fuel injectors ?

Just wanted to make sure this was my problem before I send them out to be cleaned, trying to source some 1000cc locally to swap them in real quick to make sure thatís my problem



~turbohair~

Posts: 716 | From: san diego california | Member Since: 10/13/10 | IP: (2600:1700:ff80:f) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 41 anonymous users are browsing this forum.

Galant VR4.org Moderator:  Hertz, curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 477

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.094 seconds in which 0.069 seconds were spent on a total of 14 queries. Turbo powered.



Hertz's Galant VR-4 Page