GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Newbies » Need DSM mechanic near chicagoland
Previous thread Next thread

Need DSM mechanic near chicagoland


mscatchell
Newbie


Galant VR-4 org Post #: 1238546 posted 07/15/17 08:37 AM     Remind Me!  Send Private Message   Edit Post      
I having an eletrical/charging system issue (no dash lights). Had to leave the jump box on the car last night to make it home. Looks like no HIN today
It seems like the alternator is putting out volts not sure about amps. Would appreciate any help

Posts: 9 | From: Morton Grove, Illinois | Member Since: 03/22/17 | IP: (2602:306:3711:8d) | Report this post to a Moderator

rgeier11
sled driving mullet brain


Galant VR-4 org Post #: 1238551 posted 07/15/17 03:02 PM     Remind Me!  Send Private Message   Edit Post      
Remove the alternator and take it to autozone for testing. If you can not perform this task, post your car for sale.



1992 GVR-4 #649/1000 SOLD
1998 3000GT VR4 1of19 in New Zealand Green
1992 TSI AWD

Posts: 726 | From: Chicago Suburbs, IL | Member Since: 09/26/04 | IP: (98.220.229.154) | Report this post to a Moderator

mooserage
New Title
254/2000


Galant VR-4 org Post #: 1238552 posted 07/15/17 04:29 PM     Remind Me!  Send Private Message   Edit Post      
Hmm, I'm not sure you'll need to sell your car, but you should start with checking the alternator. There are FSMs available if you need how-to help on removing the alternator. You can also search your symptoms on the board and will find similar threads with these types of issues and how people resolved them.

The alternators on these cars often overheat due to proximity to the turbo, and wear prematurely. So it's the best place to start in your case. Good luck!



-254/2000 Summit White DD (aka "The Yeti")

The Yeti loves winter and hates me.

-ムースライジュ


Edited by mooserage (07/15/17 04:30 PM)

Posts: 1137 | From: Seattle, WA | Member Since: 05/17/04 | IP: (73.97.159.114) | Report this post to a Moderator

mscatchell
Newbie


Galant VR-4 org Post #: 1238580 posted 07/17/17 07:55 AM     Remind Me!  Send Private Message   Edit Post      
There's a whole story behind the issue. But I literally would have to type a story. On a more recent note, Friday night I pulled it out the garage no prob. Went a hr later to start, click nothing (no crank no start) Put the jumper box, starts no prob. Go for drive, only lasted 5-10 mins. Car literally just shuts off and dies. Then the whole part from 1st post with driving back with the jumper box on.

Unforunately for me 2 autozone's in my area - their alternator testers don't work. That's why I haven't removed it for testing.
But they told me the battery is good (12.83v), if battery is good why no cranking?
I've had the car 4 months, battery that originally came with it was 4 yrs old was replaced recently after a no start one night in the garage. Autozone said battery was no good
The car used to start up from time to time no problem, after I initially started driving the car after it got delivered off the truck.
So when I first got the car, I figured battery was weak from sitting. I've never had the charging systems checked since it started everytime after that.

This is my 1st 4g63 so with the car being a 87' JDM I don't know what to expect with the alternator,
I can turn a wrench just don't wanna waste my time.

Posts: 9 | From: Morton Grove, Illinois | Member Since: 03/22/17 | IP: (2602:306:3711:8d) | Report this post to a Moderator

thomcasey
I ain't no puny human
1025/2000


Galant VR-4 org Post #: 1238581 posted 07/17/17 08:16 AM     Remind Me!  Send Private Message   Edit Post      
87?? Pretty sure 88 was the first year JDM Galants were produced. On the no crank note, sounds like bad grounds. Test and replace.



Thom
1991 GVR-4 1025/2000 (PTE 1200's, 16g, DSMLink v3, gm-maf, eagle/ross, .020 over, 272's)

Posts: 617 | From: Indianapolis, IN | Member Since: 09/24/14 | IP: (12.109.79.254) | Report this post to a Moderator

fuel
"Just to be pedantic!"


Galant VR-4 org Post #: 1238584 posted 07/17/17 08:54 AM     Remind Me!  Send Private Message   Edit Post      
No, the first JDM's were assembled mid way though 1987 and sold as 1987 models. Everywhere else around the world the model year of the car is the year the car was manufactured/first registered. In the US, the model year is the year ahead of when the car was actually made, because I dunno... America?



'91 E39A Galant VR-4 Evolution | '80 A164A Eterna GSR Turbo

-- Visit my JDM Galant VR-4 info & specifications site here! --

Posts: 2017 | From: Toronto, ON, Canada | Member Since: 02/23/09 | IP: (209.226.66.172) | Report this post to a Moderator

fuel
"Just to be pedantic!"


Galant VR-4 org Post #: 1238585 posted 07/17/17 08:57 AM     Remind Me!  Send Private Message   Edit Post      
Quoting mscatchell:

There's a whole story behind the issue. But I literally would have to type a story. On a more recent note, Friday night I pulled it out the garage no prob. Went a hr later to start, click nothing (no crank no start) Put the jumper box, starts no prob. Go for drive, only lasted 5-10 mins. Car literally just shuts off and dies. Then the whole part from 1st post with driving back with the jumper box on.

Unforunately for me 2 autozone's in my area - their alternator testers don't work. That's why I haven't removed it for testing.
But they told me the battery is good (12.83v), if battery is good why no cranking?
I've had the car 4 months, battery that originally came with it was 4 yrs old was replaced recently after a no start one night in the garage. Autozone said battery was no good
The car used to start up from time to time no problem, after I initially started driving the car after it got delivered off the truck.
So when I first got the car, I figured battery was weak from sitting. I've never had the charging systems checked since it started everytime after that.

This is my 1st 4g63 so with the car being a 87' JDM I don't know what to expect with the alternator,
I can turn a wrench just don't wanna waste my time.




If you have a Galant VR-4, especially a JDM Galant VR-4 then your car is a MMC. It is not a DSM in any shape or form.



'91 E39A Galant VR-4 Evolution | '80 A164A Eterna GSR Turbo

-- Visit my JDM Galant VR-4 info & specifications site here! --

Posts: 2017 | From: Toronto, ON, Canada | Member Since: 02/23/09 | IP: (209.226.66.172) | Report this post to a Moderator

iceman69510
Turn Right Racing
855/2000
828/1000


Galant VR-4 org Post #: 1238587 posted 07/17/17 10:03 AM     Remind Me!  Send Private Message   Edit Post      
Quoting thomcasey:

87?? Pretty sure 88 was the first year JDM Galants were produced. On the no crank note, sounds like bad grounds. Test and replace.




Along with this, check the cables for corrosion. I can crawl up inside the insulation. Wire can't move enough current to turn the starter.



91 VR4 855 Nile Black
92 VR4 828 Belize Green-Daily driver status
91 VR4 115 Nile Black -SOLD

Posts: 10358 | From: Michigan | Member Since: 03/05/01 | IP: (205.144.100.200) | Report this post to a Moderator

mscatchell
Newbie


Galant VR-4 org Post #: 1238606 posted 07/18/17 12:08 PM     Remind Me!  Send Private Message   Edit Post      
Going with what FUEL stated my car shows a manufacture date of June 1987 and the forms say 1987 Galant

Posts: 9 | From: Morton Grove, Illinois | Member Since: 03/22/17 | IP: (2602:306:3711:8d) | Report this post to a Moderator

mscatchell
Newbie


Galant VR-4 org Post #: 1238608 posted 07/18/17 12:14 PM     Remind Me!  Send Private Message   Edit Post      
Thanks for the feedback guys, I'll get the charging system checked. I'll also check the ground wires for corrosion, I noticed the clock and radio reset after it died while driving and when it went click dead in the driveway.

Posts: 9 | From: Morton Grove, Illinois | Member Since: 03/22/17 | IP: (2602:306:3711:8d) | Report this post to a Moderator

thomcasey
I ain't no puny human
1025/2000


Galant VR-4 org Post #: 1238610 posted 07/18/17 12:47 PM     Remind Me!  Send Private Message   Edit Post   
Yup, Mine did that. I replaced every ground wire outside of the ECU harness and fixed the issue.



Thom
1991 GVR-4 1025/2000 (PTE 1200's, 16g, DSMLink v3, gm-maf, eagle/ross, .020 over, 272's)

Posts: 617 | From: Indianapolis, IN | Member Since: 09/24/14 | IP: (12.109.79.254) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 13 anonymous users are browsing this forum.

Galant VR4.org Moderator:  Hertz, curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 230

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.06 seconds in which 0.005 seconds were spent on a total of 13 queries. Turbo powered.



Hertz's Galant VR-4 Page