GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Newbies » Re: New owner- ?/1000 Summit white from Colorado
Previous thread Next thread

Re: New owner- ?/1000 Summit white from Colorado


highrpm666
Member
677/1000


Galant VR-4 org Post #: 1188354 posted 09/10/14 04:32 PM     Remind Me!  Send Private Message   Edit Post      
^ Wishful thinking! I have twice since installing the new clutch/pivot ball+shim/fork. Same exact issue with zero change.

My clutch engagement point is good. I can shift between all gears running with the car stopped hot or cold. No drag and no reverse clunks. My slave is extending fully hot or cold. Clutch fork rests in proper position. Master and slave are both new oem parts and properly bled. Clutch pedal assembly seems good, I think its been rebuilt.

The only parts that arent brand new are the trans/synchros, clutch line, and possibly the pedal assembly.

The tranny has been through hell with the previous owner. He drove it with improper rod adjustment and a flyhweel that had been cut too many times without a pivot ball shim for far too long and trashed it. Unfortunately he and his "mechanic" had very little knowledge. He just kept forcing it into gear for who knows how many miles.

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b014:e) | Report this post to a Moderator

coyotes
Hipster VR4
1226/2000


Galant VR-4 org Post #: 1188355 posted 09/10/14 04:34 PM     Remind Me!  Send Private Message   Edit Post      
Suck. My 2nd gear is like that, synchro has seen better days.



1226/2000

Posts: 1544 | From: Seattle, WA | Member Since: 11/15/13 | IP: (172.56.32.189) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1188358 posted 09/10/14 04:55 PM     Remind Me!  Send Private Message   Edit Post      
Ya know it really does keep me from driving the car hard though. Its a good reminder to not go WOT untuned with no supporting mods on this 16g when it grinds



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD


Edited by highrpm666 (09/10/14 04:57 PM)

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b014:e) | Report this post to a Moderator

coyotes
Hipster VR4
1226/2000


Galant VR-4 org Post #: 1188361 posted 09/10/14 05:08 PM     Remind Me!  Send Private Message   Edit Post      
Why not? My research has shown that the stock fuel system can handle a 16g at stock boost levels.



1226/2000

Posts: 1544 | From: Seattle, WA | Member Since: 11/15/13 | IP: (172.56.32.189) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1188362 posted 09/10/14 05:14 PM     Remind Me!  Send Private Message   Edit Post      
I still do some WOT pulls in 3rd and 4th occasionally. Its impossible not to. It just runs and sounds so good! This is currently my only car so I gotta make sure it stays running for now! If she blew up I would be screwed



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b014:e) | Report this post to a Moderator

coyotes
Hipster VR4
1226/2000


Galant VR-4 org Post #: 1188365 posted 09/10/14 05:37 PM     Remind Me!  Send Private Message   Edit Post      
Probably a safe bet. I drive like a grandma anyways. Do you get any creep with your 16g?



1226/2000

Posts: 1544 | From: Seattle, WA | Member Since: 11/15/13 | IP: (172.56.32.189) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1188376 posted 09/10/14 06:19 PM     Remind Me!  Send Private Message   Edit Post      
No creep at all. I did get quite the jump in boost after putting the exhaust on though. It went up about 3 psi and I had to re adjust my boost controller to get it back down.



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b014:e) | Report this post to a Moderator

coyotes
Hipster VR4
1226/2000


Galant VR-4 org Post #: 1188377 posted 09/10/14 06:20 PM     Remind Me!  Send Private Message   Edit Post      
I have no boost gauge so I don't know if I am creeping or not. My driving is conservative though and I don't go WOT so it is not a problem. Exhaust and FMIC did do a huge improvement in power on my car though, for sure. turbo came after but not that big of a jump at stock boost levels.



1226/2000

Posts: 1544 | From: Seattle, WA | Member Since: 11/15/13 | IP: (172.56.32.189) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1188397 posted 09/10/14 09:15 PM     Remind Me!  Send Private Message   Edit Post      
Get your self a boost gauge and mbc! I'm sure your around 14-15psi and you may be spiking 18+. A manual boost controller and a boost gauge is a must. If I remember correctly you are running basically stock other than an evo 3 16g, fmic and 3" downpipe and 1g 3" exhaust. Turning that boost back down till you get your fuel system and ecu up to snuff may save your engine from some possible damage even if your not going wot.

Its an old set of articles but definetly a good read. Go to turbomagazine.com and type "galant vr4" into the search bar. Its a good write up on modifying the vr4 and shows gains in stages over multiple articles. It all starts in the first article with the addition of a k&n filter and full 2.5" turbo-back. The gains are very impressive and it goes on from there. Not limited to but including the 16g as the first turbo upgrade. They also describe the boost level increase from the bolt ons when using the stock bcs.



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b014:e) | Report this post to a Moderator

coyotes
Hipster VR4
1226/2000


Galant VR-4 org Post #: 1188460 posted 09/11/14 01:34 PM     Remind Me!  Send Private Message   Edit Post      
I have a logger, injectors don't see more than 75% duty cycle at WOT, my ECU is pulling fuel in mid and high range RPMs.. only ever seen 1 count of knock at most through the MMCD logger. I think I'm ok.

But I am buying parts to be in better control over my fuel system, yes.



1226/2000


Edited by coyotes (09/11/14 01:48 PM)

Posts: 1544 | From: Seattle, WA | Member Since: 11/15/13 | IP: (67.40.209.86) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1188526 posted 09/11/14 11:06 PM     Remind Me!  Send Private Message   Edit Post      
^That sounds pretty good. How has the mmcd logger worked for you? I've been curious about this. Seems to be a few style cables/supported devices available also, which are you using?



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b014:e) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1190469 posted 10/02/14 11:18 PM     Remind Me!  Send Private Message   Edit Post      
Picked up a used transmission yesterday. Its a Jdm box "C5OPH FG0108" switchable 2wd/4wd 22 spline 3.545FD. Its said to shift like butter. Came from 554/1000 to the best of my knowledge. I havent been able to track it any further back than that.




Hoping to swap it in very soon. Gotta pick up some new axle seals and clean it up a bit more. I plan on picking up the matching transfer case too otherwise I will be swapping out the 22 for my 23 spline shaft if possible. Hoping this will be a good temporary solution to my synchro blues!

And my fans quit working. Havent been able to properly diagnose the issue yet. Only way they will work is if I jump the blue wire on the back of the thermostat housing to ground. I get nothing but relay clicks when I jump the fan switch on the radiator and cant seem to figure it out. hoping to dig into this when I pull the trans.

And the isc went bad. Pretty sure the ecu is damaged. Bummer. Still idles great though once warm? One coil on the isc has very high resistance.

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b02d:4) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1198369 posted 01/08/15 08:36 PM     Remind Me!  Send Private Message   Edit Post      
Progress report:

I've put 5100 miles on her now. It runs like a charm. Fixed my hot start issue by replacing injector #3. Starts up and runs fine every time!

Replaced the transmission today with the jdm switchable box I picked up. Shifts great now. Had to put my 23 spline output shaft from my usdm trans in. Worked out very well. I also replaced both axle seals and the output shaft seal. This time around I used 75-90 valvoline gl4. It's just amazing to be able to up and downshift without grinds, lockouts etc.

Put new tires on her a few weeks ago. Went up to a 205/60/15. They are Sumic gt60's. Cheap tires. Paid $181. Good bang for the buck I suppose. They do seem to follow grooved concrete badly but otherwise they have been great.

My orange dash light randomly quit working. I haven't really looked into the cause but it's on my to do list now.

Picked up ecmlink v3 with a tel ecu and cable. It appears to be brand new and never used. Ecu is freshly recapped and socketed by ecmlink. I'm going to pick up an Innovative lc2 wideband setup and get link installed asap. Gotta replace my ISC still too. I cannot wait to learn how to tune. Got a couple gearhead buddies here in town, 559/2000 and 1309/2000 who are going to help me learn the ins and outs of link.

I've been having loads of fun in the snow recently. I absolutely love this car in bad weather. It's a friggin drift tractor. It reminds me of my '05 sti but with much more traction on ice and snow. It's a donut machine for sure! Very predictable and it's easy to be a snow parking lot Ken Block.

All in all its hands down the best car I've ever owned. Love everything about it! More updates coming soon.

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2601:1:c181:7706) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1200048 posted 01/29/15 02:41 AM     Remind Me!  Send Private Message   Edit Post      
Wideband and Ecmlink v3 installed as of tonight. spent he better part of the evening with the install. got her partially tuned and drivable. Going to work on the tune some more and attempt to milk some more power out of her tomorrow

next day edit: Got the tune setup pretty well today. She is now running 15psi and everything is looking great in link. It runs a million times better than before with a very noticeable power gain. the exhaust note is much healthier sounding as well. Very happy with the results. A big thanks to the owner of 559/2000 for help with the tune and install!



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD


Edited by highrpm666 (01/29/15 11:07 PM)

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (98.245.147.228) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1203565 posted 03/09/15 04:09 PM     Remind Me!  Send Private Message   Edit Post      
Today is the one year anniversary of owning my vr4. I've put 7000 miles on her now. Runs great other than a new deceleration vibration thats been happening intermittently for the last 1000 or so miles. Still haven't put the car on the lift to see what's going on as I've been waiting for it to get worse so it will be obvious when I got to diagnose the issue. Only happens when decelerating in 4th between 45 and 30 mph And it feels to be coming from the rear end. It started after I cleaned about 200lbs of crap out of my trunk.

I'm ordering her an anniversary gift today... evo maf, 660cc injectors and a fuel pump! Next up is a fmic!

I tried to upload some pics but the uploader isn't working for me today. I'll try again later.



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b001:d) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1204358 posted 03/19/15 03:13 PM     Remind Me!  Send Private Message   Edit Post      
Someone tried to steal 677 last night. They ruined my drivers lock cylinder trying to pick the lock. They were very careful not to damage anything but the lock cylinder thankfully. Now my key won't go in more than about an inch and it won't unlock or lock from the drivers side. Passenger side was untouched. Got a new lock cylinder ordered from the dealer. $36. It just makes me furious that someone tried to take her. Tonight I'm getting a 12 pack and a lawn chair and I'm gonna sit and watch, rifle in hand



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b003:a) | Report this post to a Moderator

G
obsessed with the turds of others
486/1000


Galant VR-4 org Post #: 1204359 posted 03/19/15 04:01 PM     Remind Me!  Send Private Message   Edit Post      
How about an aftermarket alarm?



www.japanesenostalgiccar.com
www.nostalgic.co.jp

Posts: 8786 | From: zompton | Member Since: 02/24/04 | IP: (50.193.76.1) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1204361 posted 03/19/15 04:06 PM     Remind Me!  Send Private Message   Edit Post      
I'm going alarm shopping next week after I read every online review I can find for various alarm systems!



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b003:a) | Report this post to a Moderator

G
obsessed with the turds of others
486/1000


Galant VR-4 org Post #: 1204380 posted 03/19/15 08:57 PM     Remind Me!  Send Private Message   Edit Post      
I like the encore alarms.



www.japanesenostalgiccar.com
www.nostalgic.co.jp

Posts: 8786 | From: zompton | Member Since: 02/24/04 | IP: (75.86.151.204) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


Galant VR-4 org Post #: 1204419 posted 03/20/15 09:49 AM     Remind Me!  Send Private Message   Edit Post      
id say the decel vibration it the carrier bearings and u-joints in the driveshaft. get the rebuild kit from JNZ.



138/2000 - BG - Dorothy

Posts: 3339 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (24.182.22.217) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1204432 posted 03/20/15 01:01 PM     Remind Me!  Send Private Message   Edit Post      
I put her on the lift yesterday and found my second u-joint at the first carrier loose. I'm going to replace the one and go from there. My driveshaft was completely rebuilt right before I bought the car. Still has a shiny sticker from the driveline shop that did the work. Can't believe I've already got a bad u joint. I really hope that it's the source of the vibration. My carrier bearings look and feel to be ok But I may replace them anyway just to eliminate them as a potential cause.



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2600:100e:b003:a) | Report this post to a Moderator

transparentdsm
I have to say something dumb Member
138/2000


Galant VR-4 org Post #: 1204443 posted 03/20/15 05:47 PM     Remind Me!  Send Private Message   Edit Post      
Well if the shop didn't use oem parts, like JNZ, the u-joints will be thinner and weaker. Also the carrier bearings rubber will fall apart faster then OEM ones.



138/2000 - BG - Dorothy

Posts: 3339 | From: Klamath Falls, Or | Member Since: 07/27/11 | IP: (24.182.22.217) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1213969 posted 08/04/15 04:31 PM     Remind Me!  Send Private Message   Edit Post      
Haven't had a chance to update in a while.. I have put just over 10,000 miles on her now. Been running very good with no issues other than the drive shaft vibration and a few minor things. I still plan on rebuilding the drive shaft soon but since my shop has been so busy I haven't got any bay time to do so. I will probably wait till we slow down and yank the drive shaft out for some new goodies.

I have been collecting parts for the car since my last update. So far I've picked up...
3g lifters
A used drivers side auto seatbelt assembly
A used master window switch - Installed already
New OE radiator hoses
399 maf with Blox filter and adapter harness
Denso 660cc injectors
Evo 9 fuel pump
Hood strut kit- installed already
New BC BR coilovers
27x7x2.5 FMIC

Should have the coilovers installed and the car re aligned tomorrow. I'm hoping to get the MAF, injectors and fuel pump in very soon and get it tuned again. Then I will be taking it to a local Tig guy when I have a chance to have custom charge pipes made and the intercooler installed with another tune as well.

I've got to meet quite a few gvr4 owners here in Denver and we have a nice little group of running and daily driven galants. From 600whp beasts all the way down to my nearly stock DD. Its pretty neat having this many people around driving gvr4's

And the pics!






VR4 677/1000-rebadged. AKA Charlie the turbo slut DD


Edited by highrpm666 (08/04/15 04:38 PM)

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2601:283:4403:b7) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1213970 posted 08/04/15 04:41 PM     Remind Me!  Send Private Message   Edit Post      
Tried to post a bunch more really good pics but the image up-loader isn't working after the first two. not sure whats up with that.



VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2601:283:4403:b7) | Report this post to a Moderator

highrpm666
Member
677/1000


Galant VR-4 org Post #: 1214709 posted 08/15/15 10:25 PM     Remind Me!  Send Private Message   Edit Post   




VR4 677/1000-rebadged. AKA Charlie the turbo slut DD

Posts: 117 | From: Morrison, Co | Member Since: 02/19/14 | IP: (2601:283:4403:b7) | Report this post to a Moderator


Pages: 1 | 2 | 3 | 4 | 5 | 6
Previous thread Next thread

Extra information
0 registered and 17 anonymous users are browsing this forum.

Galant VR4.org Moderator:  Hertz, curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 13090

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.363 seconds in which 0.287 seconds were spent on a total of 14 queries. Turbo powered.



Hertz's Galant VR-4 Page