GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » General VR4 Discussions » Oil Filter - Problem WIX
Previous thread Next thread

Oil Filter - Problem WIX


Dan D
220, 221... whatever it takes
410/2000


Galant VR-4 org Post #: 1241509 posted 02/04/18 11:42 AM     Remind Me!  Send Private Message   Edit Post      
For the last 20 years of changing oil on it, I've switched back and forth between Purolator and Wix filters. Never had a problem with either. Changed the oil yesterday. New Wix filter from Amazon. Went for drive this morning and the oil pressure was going ape-$hit. Spiking my 0-150 gauge at 4800rpm and not acting linearly. Drove it home found some seepage around the filter housing. Checked the sender with a DMM - All good. Checked the gauge with some resistors - all good. Swapped in the other oil filter I ordered (also Wix). Drove again and it's good.

Never had that before but I'll probably be skipping the Wix filters from now on. Think if one doesn't have an aftermarket gauge and never knew it was doing that.



#410/2k

Posts: 1141 | From: Brownsburg, IN | Member Since: 02/27/01 | IP: (2601:805:c700:2e) | Report this post to a Moderator

turbowop
Hard Snarker
1051/2000



Galant VR-4 org Post #: 1241515 posted 02/05/18 05:58 PM     Remind Me!  Send Private Message   Edit Post      
Open up the filter and see what's up with it. I've never had an issue with Wix filters and that's all I've ever used on 1051.



-Mark

A face only a grocery shopper could love.
1051

Posts: 11858 | From: Yakima, WA | Member Since: 04/29/01 | IP: (68.113.4.116) | Report this post to a Moderator

Dan D
220, 221... whatever it takes
410/2000


Galant VR-4 org Post #: 1241521 posted 02/06/18 01:44 PM     Remind Me!  Send Private Message   Edit Post      
Amazon refunded it without return so I'll open it up this weekend if I get a few minutes.



#410/2k

Posts: 1141 | From: Brownsburg, IN | Member Since: 02/27/01 | IP: (158.52.10.12) | Report this post to a Moderator

turbowop
Hard Snarker
1051/2000



Galant VR-4 org Post #: 1241522 posted 02/06/18 02:52 PM     Remind Me!  Send Private Message   Edit Post      
Quoting Bravolawson:

Turbowop, I could swear that I read a post of yours a long time ago (around 2006) where you said that you used the Napa Gold filters.




Yup, and I still do. But those Napa Golds are made by Wix.



-Mark

A face only a grocery shopper could love.
1051

Posts: 11858 | From: Yakima, WA | Member Since: 04/29/01 | IP: (68.113.4.116) | Report this post to a Moderator

Dan D
220, 221... whatever it takes
410/2000


Galant VR-4 org Post #: 1241585 posted 02/10/18 02:18 PM     Remind Me!  Send Private Message   Edit Post   
Cut it open. (messy!). Nothing. I don't see anything wrong unless the filter media is bad. Part stack up was correct. Relief seems to move as expected. Tension spring seems ok. Anti-drainback was facing the right way. ??



#410/2k

Posts: 1141 | From: Brownsburg, IN | Member Since: 02/27/01 | IP: (2601:805:c700:2e) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 18 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 271

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.22 seconds in which 0.208 seconds were spent on a total of 14 queries. Turbo powered.



Hertz's Galant VR-4 Page