GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » Galant 2.0 GLS TDI - random loss of power when driving
Previous thread Next thread

Galant 2.0 GLS TDI - random loss of power when driving


Oliveira
Newbie


Galant VR-4 org Post #: 1233354 posted 11/11/16 03:16 AM     Remind Me!  Send Private Message   Edit Post      
Hi
1st of all thanks for the time you guys are spending on my topic.

I'm new at this forum
I'm having a trouble with my Galant 4D68 engine (1999 year) aceleration. It randomly exhitate on aceleration.
Sometimes going down a hill the Service Light switch on, and when it happens if I press the acelerator pedal it reacts as almost no pressing it... and if going up a hill it only runs at 1st gear at 2000 - 2500 rpm (more or less) as no power at all... the car just runs as in safe mode...the idle is perfect, no smoke, no noise, temperature looks ok; just no power at all...
I was wondering may should be the crankshaft position sensor... but already check with multimeter and it looks ok...(anyway it's a random issue)
If I restart the engine the power is back again and everything looks good again and the service light switch off.
other information is that I noticed that when weather is hot it happens worse and much frequently...

any information or tips is really apretiated.

thanks guys
Xavier

Posts: 2 | From: Funchal - Madeira Island | Member Since: 03/19/16 | IP: (84.23.208.243) | Report this post to a Moderator

fuel
"Just to be pedantic!"


Galant VR-4 org Post #: 1233388 posted 11/12/16 01:31 AM     Remind Me!  Send Private Message   Edit Post      
Hi Xavier,

This forum caters primarily to the 6th generation Galant 1987-1992 - specifically the VR-4 model equipped with the 4G63 turbo and AWD/AWS. Unfortunately very few, if any (myself included), will have experience with the 8th generation Galant with the 4D68 Diesel.



'91 E39A Galant VR-4 Evolution | '80 A164A Eterna GSR Turbo

-- Visit my JDM Galant VR-4 info & specifications site here! --

Posts: 2106 | From: Toronto, ON, Canada | Member Since: 02/23/09 | IP: (180.181.213.100) | Report this post to a Moderator

Oliveira
Newbie


Galant VR-4 org Post #: 1233423 posted 11/14/16 09:22 AM     Remind Me!  Send Private Message   Edit Post      
Thanks Mate

Anyway I'm trying to resolve it... Geting a bit information from everywhere I will manage it

I made the ECU Self Diagnosis and got few errors/fault codes on ABS Brackes and Engine Injection System Sensors... already got the Inspection Chart for Diagnosis Codes, so now I need to face the beast and resolve it.

Thanks so much for the reply and considerations

Cheers
Xavier

Posts: 2 | From: Funchal - Madeira Island | Member Since: 03/19/16 | IP: (84.23.208.243) | Report this post to a Moderator

fuel
"Just to be pedantic!"


Galant VR-4 org Post #: 1233445 posted 11/14/16 05:13 PM     Remind Me!  Send Private Message   Edit Post      
Let us know how you get on! The 4D68 Galant certainly is a rare car!



'91 E39A Galant VR-4 Evolution | '80 A164A Eterna GSR Turbo

-- Visit my JDM Galant VR-4 info & specifications site here! --

Posts: 2106 | From: Toronto, ON, Canada | Member Since: 02/23/09 | IP: (220.244.112.238) | Report this post to a Moderator

Breakerrr
Junior Member
1512/2000
362/2000


Galant VR-4 org Post #: 1234365 posted 12/23/16 02:47 AM     Remind Me!  Send Private Message   Edit Post      
I don't know if it'll help or even if it's relevant to the model Galant you have, but the symptoms are consistent with a faulty engine temp sensor. Anyway...good luck.



Read The Instructions

Posts: 51 | From: Wheat Ridge,CO | Member Since: 01/27/16 | IP: (2607:fb90:6cbc:2) | Report this post to a Moderator

Ben
Member


Galant VR-4 org Post #: 1234391 posted 12/24/16 08:34 AM     Remind Me!  Send Private Message   Edit Post      
Not likely the cause, but replace the fuel filter. For most drivability issues on any diesel engine, it's a good idea too start with a new fuel filter.

Posts: 199 | From: Lubbock, Tx | Member Since: 01/14/09 | IP: (72.26.142.229) | Report this post to a Moderator

FlyingEagle Galant VR4.org Moderator
Eager Beaver


Galant VR-4 org Post #: 1234453 posted 12/27/16 06:45 PM     Remind Me!  Send Private Message   Edit Post      
^^^ Just be darn sure you know how to prefill and evacuate the fuel system of air bubbles before you crank it over and try to start it.

ANY air in the fuel line and you could be stuck with a no start situation for quite some time. I learned the hard way when I performed a fuel filter swap on a VW diesel and forgot to fully prime/fill the fuel filter first and then prime/bleed the system. If this is a "lift" or "suction" from the tank, to the filter, and on up the fuel pump, then this can happen.



C53A 1 of the ~1500

Posts: 1589 | From: THE Ottawa | Member Since: 03/05/05 | IP: (99.224.82.138) | Report this post to a Moderator

fuel
"Just to be pedantic!"


Galant VR-4 org Post #: 1234463 posted 12/27/16 09:30 PM     Remind Me!  Send Private Message   Edit Post   
Quoting Breakerrr:

I don't know if it'll help or even if it's relevant to the model Galant you have, but the symptoms are consistent with a faulty engine temp sensor. Anyway...good luck.



Given that the 4D68 Diesel in the Galant has mechanical injection (pre TDI days), the water temp sensor is purely for the gauge cluster and not for the ECU (which doesn't exist on the 4D68).



'91 E39A Galant VR-4 Evolution | '80 A164A Eterna GSR Turbo

-- Visit my JDM Galant VR-4 info & specifications site here! --

Posts: 2106 | From: Toronto, ON, Canada | Member Since: 02/23/09 | IP: (180.181.213.100) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 11 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 1302

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.22 seconds in which 0.199 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page